accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From escribamarko <escribama...@gmail.com>
Subject Re: Failed to connect to server
Date Fri, 28 Mar 2014 03:06:28 GMT
Hi Josh,

Thank you.

I have checked the variables in accumulo-env.sh, and it seems like they are
properly configured.
I am having this issue ""You must set HADOOP_PREFIX"" only if I use
ec2-XXXXXXXX.us-west-1.compute.amazonaws.com on master/slaves files. But
when I set internal 172.30.1.78 on master/slaves file everything is working
locally. 

For a reference, here is the accumulo-env.sh

if [ -z "$HADOOP_HOME" ]
then
   test -z "$HADOOP_PREFIX"      && export HADOOP_PREFIX=$HADOOP_HDFS_HOME
else
   HADOOP_PREFIX="$HADOOP_PREFIX "
   unset HADOOP_HOME
fi
# test -z "$HADOOP_CONF_DIR"       && export
HADOOP_CONF_DIR="$HADOOP_PREFIX/conf"
# hadoop-2.0:
test -z "$HADOOP_CONF_DIR"     && export
HADOOP_CONF_DIR="$HADOOP_PREFIX/etc/hadoop"
	

test -z "$JAVA_HOME"             && export JAVA_HOME=$JAVA_HOME
test -z "$ZOOKEEPER_HOME"        && export ZOOKEEPER_HOME=$ZOOKEEPER_HOME
test -z "$ACCUMULO_LOG_DIR"      && export
ACCUMULO_LOG_DIR=$ACCUMULO_HOME/logs
if [ -f ${ACCUMULO_CONF_DIR}/accumulo.policy ]
then
   POLICY="-Djava.security.manager
-Djava.security.policy=${ACCUMULO_CONF_DIR}/accumulo.policy"
Fi
test -z "$ACCUMULO_TSERVER_OPTS" && export ACCUMULO_TSERVER_OPTS="${POLICY}
-Xmx384m -Xms384m "
test -z "$ACCUMULO_MASTER_OPTS"  && export ACCUMULO_MASTER_OPTS="${POLICY}
-Xmx128m -Xms128m"
test -z "$ACCUMULO_MONITOR_OPTS" && export ACCUMULO_MONITOR_OPTS="${POLICY}
-Xmx64m -Xms64m"
test -z "$ACCUMULO_GC_OPTS"      && export ACCUMULO_GC_OPTS="-Xmx64m
-Xms64m"
test -z "$ACCUMULO_GENERAL_OPTS" && export
ACCUMULO_GENERAL_OPTS="-XX:+UseConcMarkSweepGC
-XX:CMSInitiatingOccupancyFraction=75 -Djava$
test -z "$ACCUMULO_OTHER_OPTS"   && export ACCUMULO_OTHER_OPTS="-Xmx128m
-Xms64m"
# what do when the JVM runs out of heap memory
export ACCUMULO_KILL_CMD='kill -9 %p'

# Should the monitor bind to all network interfaces -- default: false
# export ACCUMULO_MONITOR_BIND_ALL="true"


Should I also need to add "export ACCUMULO_TSERVER_OPTS" and rest
accumulo_opts on .bashrc?

Thanks in advance.




--
View this message in context: http://apache-accumulo.1065345.n5.nabble.com/Failed-to-connect-to-server-tp8484p8520.html
Sent from the Developers mailing list archive at Nabble.com.

Mime
View raw message