accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: Accumulo 1.6.0 HA namenode testing
Date Wed, 18 Dec 2013 04:44:29 GMT
On Tue, Dec 17, 2013 at 11:39 PM, Josh Elser <josh.elser@gmail.com> wrote:

> I've been running CI tests against 1.5.1 with HA (QJM) Namenode support
> for a few weeks now. Earlier this week I started running the same against
> 1.6.0.
>
> AFAICT, everything has been fine so far. This is with the
> hdfs-agitation.pl (causing a failover using the haadmin command every ten
> minutes) script that Sean provided a while back.
>
>
I was not using the correct terminology for what I was thinking, but I am
not sure what the correct terminology is.  I do not want to be limited by
the memory of one machine for hdfs metadata and I want HA.  So would it be
correct to say that I want to test with multiple HA nameservices?   For
example test 1.6 w/ three nameservices, where each nameservice has two HA
namenodes.   This would allow hdfs metadata to spread across the memory of
three machines.


>
> On 12/17/13, 11:32 PM, Keith Turner wrote:
>
>> Has anyone has done any HA namenode testing w/ 1.6.0?
>>
>> I have started poking at viewfs:// w/ two regular namenodes and have been
>> finding issues.   I want to eventually run the test suite against Accumulo
>> 1.6.0 w/ multiple HA namenodes.
>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message