accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Havanki" <bhava...@clouderagovt.com>
Subject Re: Review Request 16224: ACCUMULO-1986 - data integrity checks for Key and Mutation Thrift constructors
Date Mon, 16 Dec 2013 14:29:29 GMT


> On Dec. 13, 2013, 2:16 p.m., Mike Drob wrote:
> > src/core/src/test/java/org/apache/accumulo/core/data/KeyTest.java, line 20
> > <https://reviews.apache.org/r/16224/diff/1/?file=397002#file397002line20>
> >
> >     Do we have official guidance against using import *? Regardless, I'd prefer
this changed.

Personally, I loosen standards a bit when it comes to unit tests, and particularly for assertXxx
methods in unit tests, everyone pretty much knows where they come from. However, I just surveyed
the unit tests and hardly any use this construct, so I'll change it to not use *.


> On Dec. 13, 2013, 2:16 p.m., Mike Drob wrote:
> > src/core/src/test/java/org/apache/accumulo/core/data/MutationTest.java, line 317
> > <https://reviews.apache.org/r/16224/diff/1/?file=397003#file397003line317>
> >
> >     Instead of renaming the method, another option would have been to qualify references
to if as this.assertEquals(...). Not sure which one is preferable. I don't like the name "checkCU"
but can't offer any alternatives, so maybe it's fine.

I don't like the assertEquals thing since it implies that it's part of JUnit. Since I will
be generating a new patch anyway, if you do think of a better name, I'll add it in.


- Bill


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/16224/#review30359
-----------------------------------------------------------


On Dec. 12, 2013, 4:32 p.m., Bill Havanki wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/16224/
> -----------------------------------------------------------
> 
> (Updated Dec. 12, 2013, 4:32 p.m.)
> 
> 
> Review request for accumulo.
> 
> 
> Bugs: ACCUMULO-1986
>     https://issues.apache.org/jira/browse/ACCUMULO-1986
> 
> 
> Repository: accumulo
> 
> 
> Description
> -------
> 
> Integrity checks for constructing Key and Mutation objects from Thrift.
> 
> To make adding unit tests easier, I updated KeyTest and MutationTest to use JUnit 4 annotations.
That drove the need to rename an assertEquals method in MutationTest, hence all the changes
to "checkCU" there.
> 
> See the JIRA ticket for a list of classes that I evaluated for these same sort of integrity
checks.
> 
> 
> Diffs
> -----
> 
>   src/core/src/main/java/org/apache/accumulo/core/data/Key.java cfb0b5c 
>   src/core/src/main/java/org/apache/accumulo/core/data/Mutation.java 3979da9 
>   src/core/src/test/java/org/apache/accumulo/core/data/KeyTest.java 9a7f0d7 
>   src/core/src/test/java/org/apache/accumulo/core/data/MutationTest.java 38ddcad 
> 
> Diff: https://reviews.apache.org/r/16224/diff/
> 
> 
> Testing
> -------
> 
> Unit tests and functional tests pass.
> 
> 
> Thanks,
> 
> Bill Havanki
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message