accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Drob" <md...@mdrob.com>
Subject Re: Review Request 16224: ACCUMULO-1986 - data integrity checks for Key and Mutation Thrift constructors
Date Fri, 13 Dec 2013 19:16:14 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/16224/#review30359
-----------------------------------------------------------



src/core/src/test/java/org/apache/accumulo/core/data/KeyTest.java
<https://reviews.apache.org/r/16224/#comment58102>

    Do we have official guidance against using import *? Regardless, I'd prefer this changed.



src/core/src/test/java/org/apache/accumulo/core/data/MutationTest.java
<https://reviews.apache.org/r/16224/#comment58103>

    Do we have official guidance against using import *? Regardless, I'd prefer this changed.



src/core/src/test/java/org/apache/accumulo/core/data/MutationTest.java
<https://reviews.apache.org/r/16224/#comment58104>

    Instead of renaming the method, another option would have been to qualify references to
if as this.assertEquals(...). Not sure which one is preferable. I don't like the name "checkCU"
but can't offer any alternatives, so maybe it's fine.


- Mike Drob


On Dec. 12, 2013, 9:32 p.m., Bill Havanki wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/16224/
> -----------------------------------------------------------
> 
> (Updated Dec. 12, 2013, 9:32 p.m.)
> 
> 
> Review request for accumulo.
> 
> 
> Bugs: ACCUMULO-1986
>     https://issues.apache.org/jira/browse/ACCUMULO-1986
> 
> 
> Repository: accumulo
> 
> 
> Description
> -------
> 
> Integrity checks for constructing Key and Mutation objects from Thrift.
> 
> To make adding unit tests easier, I updated KeyTest and MutationTest to use JUnit 4 annotations.
That drove the need to rename an assertEquals method in MutationTest, hence all the changes
to "checkCU" there.
> 
> See the JIRA ticket for a list of classes that I evaluated for these same sort of integrity
checks.
> 
> 
> Diffs
> -----
> 
>   src/core/src/main/java/org/apache/accumulo/core/data/Key.java cfb0b5c 
>   src/core/src/main/java/org/apache/accumulo/core/data/Mutation.java 3979da9 
>   src/core/src/test/java/org/apache/accumulo/core/data/KeyTest.java 9a7f0d7 
>   src/core/src/test/java/org/apache/accumulo/core/data/MutationTest.java 38ddcad 
> 
> Diff: https://reviews.apache.org/r/16224/diff/
> 
> 
> Testing
> -------
> 
> Unit tests and functional tests pass.
> 
> 
> Thanks,
> 
> Bill Havanki
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message