accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Miguel Pereira <miguelaperei...@gmail.com>
Subject Re: MiniAccumuloCluster in Servlet
Date Sat, 26 Oct 2013 16:46:56 GMT
The MiniAccumuloCluster logs only display this one line:

Error: Could not find or load main class org.apache.accumulo.start.Main

That's it :/ Which leads me to believe there is something wrong with my
tomcat configuration?



On Sat, Oct 26, 2013 at 12:14 PM, Josh Elser <josh.elser@gmail.com> wrote:

> Miguel,
>
> Check the logs directory underneath the directory you provided to
> MiniAccumuloCluster.
>
> Check the non-empty files. You'll likely find something there that tells
> you what's up.
>
> On 10/26/2013 12:08 PM, Miguel Pereira wrote:
>
>> Sorry, I intended to type accumulo-*start*-1.5.0.jar
>>
>> And accumulo-server-1.5.0.jar is also there.
>>
>>
>> On Sat, Oct 26, 2013 at 11:35 AM, Billie Rinaldi
>> <billie.rinaldi@gmail.com>**wrote:
>>
>>  MAC depends on accumulo-start and accumulo-server as well.
>>>
>>> Billie
>>> On Oct 26, 2013 11:28 AM, "Miguel Pereira" <miguelapereira1@gmail.com>
>>> wrote:
>>>
>>>  Hia guys i've been stuck on this one for a while so any help is
>>>> appreciated..
>>>>
>>>> Code works as a normal java application but when I deploy it and try to
>>>> hook into a ServletContextListener to start up a MiniAccumuloCluster
>>>> I get this error in the Tomcat 7 logs:
>>>>
>>>> SEVERE: Error listenerStart
>>>> Oct 26, 2013 10:55:18 AM org.apache.catalina.core.**StandardContext
>>>> startInternal
>>>> SEVERE: Context [<myapp name>] startup failed due to previous errors
>>>>
>>>> .....
>>>>
>>>> INFO: Deploying web application archive
>>>> /usr/local/apache-tomcat-7.0.**42/<myapp name>
>>>> INITIALIZING SERVLET CONTEXT
>>>> Oct 26, 2013 10:55:18 AM org.apache.catalina.core.**StandardContext
>>>> listenerStart
>>>> SEVERE: Exception sending context initialized event to listener instance
>>>>
>>> of
>>>
>>>> class web.servlet.**MyServletContextListener
>>>> java.lang.RuntimeException: Initialize process returned 1
>>>>      at
>>>>
>>>>
>>>>  org.apache.accumulo.**minicluster.**MiniAccumuloCluster.start(**
>>> MiniAccumuloCluster.java:304)
>>>
>>>>      at
>>>>
>>>>
>>>>  web.servlet.**MyServletContextListener.**contextInitialized(**
>>> MyServletContextListener.java:**74)
>>>
>>>>      at
>>>>
>>>>
>>>>  org.apache.catalina.core.**StandardContext.listenerStart(**
>>> StandardContext.java:4939)
>>>
>>>>
>>>> The MiniAccumuloCluster logs ( Initialize and Main ) display this error:
>>>>
>>>> Error: Could not find or load main class org.apache.accumulo.start.Main
>>>>
>>>> However accumulo-core-1.5.0.jar is present in the WEB-INF/lib directory
>>>>
>>> of
>>>
>>>> the exploded war...
>>>>
>>>> Thoughs? and thanks in advance,
>>>> Miguel
>>>>
>>>>
>>>
>>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message