accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Corey Nolet <cjno...@gmail.com>
Subject Issues running Minicluster in o.a.a.start.Main
Date Sun, 06 Oct 2013 12:36:35 GMT
I'm having issues running the minicluster both in the 'accumulo proxy -p
proxy.properties' and via 'accumulo minicluster'. It looks like the
Zookeeper process is not starting and the MAC is going into an infinite
loop waiting for it to start.

I checked the Master.err logs for the minicluster command and I see the
following:

Uncaught exception: java.lang.NoClassDefFoundError:
org/apache/commons/vfs2/impl/VFSClassLoader
java.lang.NoClassDefFoundError: org/apache/commons/vfs2/impl/VFSClassLoader
at java.lang.Class.getDeclaredMethods0(Native Method)
at java.lang.Class.privateGetDeclaredMethods(Class.java:2521)
at java.lang.Class.getMethod0(Class.java:2764)
at java.lang.Class.getMethod(Class.java:1653)
at org.apache.accumulo.start.Main.main(Main.java:42)
Caused by: java.lang.ClassNotFoundException:
org.apache.commons.vfs2.impl.VFSClassLoader
at java.net.URLClassLoader$1.run(URLClassLoader.java:366)
at java.net.URLClassLoader$1.run(URLClassLoader.java:355)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:354)
at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:308)
at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
... 5 more


the commons-vfs2.jar is in Accumulo's lib directory. I'm using Hadoop 1.2.1.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message