accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ke...@deenlo.com
Subject Re: Review Request 14880: ACCUMULO-1785 Alter config.sh to optionally just verify environment instead of making changes
Date Wed, 23 Oct 2013 20:19:50 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/14880/#review27415
-----------------------------------------------------------


I would prefer to remove all of the automatic actions and replace them with messages (like
those in your patch) instructing the user what to do.   I have seen unwanted behavior in the
past.   Howerver, I do not think a behavioral  change like this should be made in 1.4.  So
I like your approach of being able to optionally suppress the automation actions.   

- kturner


On Oct. 23, 2013, 7:08 p.m., Sean Busbey wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/14880/
> -----------------------------------------------------------
> 
> (Updated Oct. 23, 2013, 7:08 p.m.)
> 
> 
> Review request for accumulo.
> 
> 
> Bugs: ACCUMULO-1785
>     https://issues.apache.org/jira/browse/ACCUMULO-1785
> 
> 
> Repository: accumulo
> 
> 
> Description
> -------
> 
> Updates config.sh to skip automagic standalone mode and avoid writing to the local filesystem
given an optional environment variable. Adds additional error handling since this changes
the invariant that a conf/masters file will exist.
> 
> 
> Diffs
> -----
> 
>   bin/config.sh 9277406 
> 
> Diff: https://reviews.apache.org/r/14880/diff/
> 
> 
> Testing
> -------
> 
> functional tests
> starting w/o env variable set and no master/slaves correctly started in standalone mode.
> starting w/env variable and no required variables and no master/slaves correctly complained
and failed.
> starting w/env variable and required variables and no master/slaves correctly init w/o
writing crap, correctly failed to use start-all
> starting with a normal cluster config
> 
> 
> Thanks,
> 
> Sean Busbey
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message