accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andres Danter <adan...@gmail.com>
Subject Accumulo 1.4.3 RPM
Date Sun, 07 Jul 2013 01:21:01 GMT
Hi all,

I ran into an odd problem and was wondering if anyone could verify a
possible issue.

I tried setting up a local yum repository that contains only the RPM for
Accumulo 1.4.3.  I created a file in /etc/yum.repos.d called local.repo.
It contains the following:

[localrepo]
name=localrepo
baseurl=file:///var/www/html/localrepo
enabled=1
gpgcheck=0

I placed the RPM in /var/www/html/localrepo/accumulo/

Then I ran the following command:

createrepo /var/www/html/localrepo

Then I ran the following:

repoquery -q --repoid=localrepo -a

Which returned nothing.  It should have listed the Accumulo RPM.

I then replaced the 1.4.3 RPM with the 1.5.0 RPM and ran the following
command:

createrepo --update /var/www/html/localrepo

Then I ran:

yum clean all

Then I re-ran:

repoquery -q --repoid=localrepo -a

This time the command returned:

accumulo-0:1.5.0-1.noarch

I was even able to install the Accumulo 1.5.0 RPM using Yum.  I was unable
to do that with the 1.4.3 RPM.

So has anyone ever successfully set up a repository with the 1.4.3 RPM?
Does anyone have any clue as to why one RPM is seen by Yum and the other is
not?  I figured it has to do with the metadata that is created when the RPM
is built, but I don't have any insight beyond that.

Thanks,

Andres

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message