accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Turner <ke...@deenlo.com>
Subject Re: [VOTE] JDK 1.7 - Switch for Accumulo 1.6.0
Date Mon, 03 Jun 2013 22:22:10 GMT
On Mon, Jun 3, 2013 at 5:21 PM, Sean Busbey <busbey@cloudera.com> wrote:

> Dropping JDK6 support is a pretty big deal.
>
> Is it worth making it a 2.0.0 feature instead of 1.6.0?
>
> If not, what would be the distinction for a 2.0.0?
>

One thing 2.0 could be used for is a new incompatible API.


>
> In the mean time we could explicitly change testing to be on JDK7 instead
> of JDK6 as an initial step.
>
>
> On Mon, Jun 3, 2013 at 4:51 PM, Christopher <ctubbsii@apache.org> wrote:
>
> > Given all the previous discussions about this, and assuming all points
> > and counterpoints have already been sufficiently enumerated, I'd like
> > to put it to a vote, explicitly:
> >
> > Should we switch to JDK 1.7 for Accumulo 1.6.0, to take advantage of
> > newer features (ACCUMULO-905), or should we continue to require that
> > Accumulo 1.6.0 run on JRE 1.6?
> >
> > --
> > Christopher L Tubbs II
> > http://gravatar.com/ctubbsii
> >
>
>
>
> --
> Sean Busbey
> Solutions Architect
> Cloudera, Inc.
> Phone: MAN-VS-BEARD
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message