accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christopher <ctubb...@apache.org>
Subject Re: did something change to requite maven 3 recently?
Date Thu, 11 Apr 2013 02:52:07 GMT
Some of the latest maven plugins, (most notably the maven-site-plugin)
either will not work, or will not work as well, or not work in the
same way with older versions of Maven. I updated the enforcer plugin,
as part of my updates for ACCUMULO-924, to enforce these requirements,
in order to ensure build consistency/repeatability throughout the
build.

This really isn't a new requirement, just a newly enforced one for >=1.5.

--
Christopher L Tubbs II
http://gravatar.com/ctubbsii


On Wed, Apr 10, 2013 at 8:54 PM, David Medinets
<david.medinets@gmail.com> wrote:
> I pulled the latest trunk and ran into this message.
>
> root@li459-74:/usr/local/hadoop/lib# su accumulo -c "cd
> /home/accumulo/workspace/accumulo; mvn -Dmaven.test.skip=true package -P
> assemble"
> [INFO] Scanning for projects...
> [INFO]
> ------------------------------------------------------------------------
> [ERROR] BUILD FAILURE
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Unable to build project '/home/accumulo/workspace/accumulo/pom.xml;
> it requires Maven version 3.0.3
> [INFO]
> ------------------------------------------------------------------------
> [INFO] For more information, run Maven with the -e switch
> [INFO]
> ------------------------------------------------------------------------
> [INFO] Total time: < 1 second
> [INFO] Finished at: Thu Apr 11 00:52:17 UTC 2013
> [INFO] Final Memory: 1M/7M
> [INFO]
> ------------------------------------------------------------------------

Mime
View raw message