accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject Re: VFS class reloading?
Date Wed, 17 Apr 2013 00:54:29 GMT
Likely. I just followed the directions in the README as I have not kept up with all of the
changes in 1.5. It seems that maybe we should have Jenkins build with all of the different
profile variations, or at least the ones that we use as examples in the README. 

----- Original Message -----
From: "Josh Elser" <> 
Sent: Tuesday, April 16, 2013 8:49:40 PM 
Subject: Re: VFS class reloading? 

I wish I could tell you that it worked on my machine, but alas the 
command below did fail on a bunch of core tests via 

Looking into it currently. Maybe someone accidentally broke 
compatibility with the old Hadoop stuff and we need to add a new 
dependency with 

On 04/16/2013 08:39 PM, wrote: 
> Updated my local 1.5 branch and tried to build with "mvn clean package -P assemble -Dhadoop.version=".
I'm running CDH3 Update 3 locally, so that should work. A bunch of tests failed in core with:

> Caused by: java.lang.ClassNotFoundException:

> at$ 
> at Method) 
> at 
> at java.lang.ClassLoader.loadClass( 
> at sun.misc.Launcher$AppClassLoader.loadClass( 
> at java.lang.ClassLoader.loadClass( 
> Has anyone else seen this? 
> -- Dave 
> ----- Original Message ----- 
> From: "Eric Newton" <> 
> To: 
> Sent: Tuesday, April 16, 2013 7:52:09 PM 
> Subject: Re: VFS class reloading? 
> We have tests for dynamic loading of classes so I'm pretty sure it works. 
> John, can you repeat the failure? 
> -Eric 
> On Tue, Apr 16, 2013 at 6:50 PM, Dave Marion <> wrote: 
>> Looking at the code, it should work. Keith and I had several conversations 
>> about what the new classloader should do. I believe that he wanted it to 
>> behave like the old one and what I see in the code supports that. If it is 
>> not working, then I would say create a ticket for it for now. I'll try to 
>> replicate it tonight if I have time. 
>> -----Original Message----- 
>> From: Dave Marion [] 
>> Sent: Tuesday, April 16, 2013 6:41 PM 
>> To: 
>> Subject: RE: VFS class reloading? 
>> The implementation changed several times, so the pre-1.5 layout may not 
>> work. In 1.5, using the bootstrap script, it should put the accumulo jars 
>> into HDFS and dynamic loading from there should occur. I'll try and test 
>> tonight if I have time. 
>> -----Original Message----- 
>> From: John Vines [] 
>> Sent: Tuesday, April 16, 2013 6:30 PM 
>> To: Accumulo Dev List 
>> Subject: VFS class reloading? 
>> Maybe I missed something with the switch to the VFS classloader, but does 
>> dynamic loading out of lib/ext no longer work? I had accumulo 1.5 running, 
>> threw an iterator in there, but had to restart tserver to get the new 
>> iterator picked up. Was that an intentional change? 

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message