accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Vines <vi...@apache.org>
Subject Re: MapReduceExample When Executed Displays Usage And Error Message
Date Mon, 11 Feb 2013 04:23:46 GMT
I don't think so, all of our client processes are designed to wait a bit
for the server to come up, and this process a similar behavior as our
start-all script.

Sent from my phone, please pardon the typos and brevity.
On Feb 10, 2013 10:59 PM, "David Medinets" <david.medinets@gmail.com> wrote:

> Adding a Thread.sleep(1) after the start() method does seem to
> consistently resolve the 'Stream Closed' issue.
>
>       MiniAccumuloCluster la = new MiniAccumuloCluster(tmpDir, "pass1234");
>       la.start();
>       Thread.sleep(1);
>
> Which raises a question. Should the start method wait for the
> processes to start before returning? Any reason I shouldn't create a
> jira ticket for this?
>
> On Sat, Feb 9, 2013 at 8:45 PM, Jim Klucar <klucar@gmail.com> wrote:
> > I wonder if it is just because you're starting and stopping so quickly. I
> > know the Tserver processes take a second to come up, perhaps put a sleep
> in
> > for a few seconds and see if that works.
> >
> >
> > On Sat, Feb 9, 2013 at 8:40 PM, David Medinets <david.medinets@gmail.com
> >wrote:
> >
> >> https://issues.apache.org/jira/browse/ACCUMULO-1058
> >>
> >> On Sat, Feb 9, 2013 at 8:04 PM, Christopher <ctubbsii@apache.org>
> wrote:
> >> > Should probably have documentation and a working example prior to
> 1.5.0.
> >> Is there already a ticket for it?
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message