accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Vines <vi...@apache.org>
Subject Re: MiniAccumulo or InstanceOperations or me?
Date Wed, 13 Feb 2013 18:30:49 GMT
I don't think your property is coming back because you're using
getSiteConfiguration(). I believe that just spits back the configuration
from the xml files. getSystemConfiguration() will return data as it is in
Zookeeper, which is where that property will be. I had no problems using
the shell to set a non-existant property (with an allowable prefix), read
it back, and then delete it.

As for the error, that's a bit new to me. Check to make sure there's
nothing in the master and tserver logs with it.


On Tue, Feb 12, 2013 at 9:10 PM, Jim Klucar <klucar@gmail.com> wrote:

> I'm not sure if this is a MiniAccumulo or an InstanceOperations or a me
> problem. If I do a InstanceOperations.setProperty followed by a
> getSiteConfiguration, my property isn't there. Does it have to be a
> pre-defined property?
>
> More concerning if I do a removeProperty of the property I'm setting, I'm
> seeing this:
>
> org.apache.accumulo.core.client.AccumuloException:
> org.apache.thrift.TApplicationException: Internal error processing
> removeSystemProperty
>  at org.apache.accumulo.core.client.impl.MasterClient.execute
> (MasterClient.java:123)
>
> org.apache.accumulo.core.client.admin.InstanceOperationsImpl.removeProperty
> (InstanceOperationsImpl.java:86)
>     sun.reflect.NativeMethodAccessorImpl.invoke0
> (NativeMethodAccessorImpl.java:-2)
>     sun.reflect.NativeMethodAccessorImpl.invoke
> (NativeMethodAccessorImpl.java:57)
>     sun.reflect.DelegatingMethodAccessorImpl.invoke
> (DelegatingMethodAccessorImpl.java:43)
>
> This was all on a 1.5-SNAPSHOT I made this evening.
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message