accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Newton <eric.new...@gmail.com>
Subject Re: Unhelpful Null Pointer Message (during processing of message)
Date Fri, 19 Oct 2012 15:08:03 GMT
Dave, if you can, retry with Thrift 0.9, which should happen if you svn
update.

-Eric

On Thu, Oct 18, 2012 at 10:30 AM, David Medinets
<david.medinets@gmail.com>wrote:

> Sorry, it was late and I was not thinking well enough.
>
> The message was in the tserver log. All components (hadoop, zookeeper,
> and accumulo) ran on one virtual Ubuntu (latest version) Linode
> server. Accumulo Trunk and Thrift 0.8.
>
> I can easily rebuild the server and try a configuration change or any
> other suggestion.
>
> On Thu, Oct 18, 2012 at 8:38 AM, Eric Newton <eric.newton@gmail.com>
> wrote:
> > Which server had this error?  What version of accumulo?  What version of
> > thrift?
> >
> > -Eric
> >
> > On Wed, Oct 17, 2012 at 10:26 PM, David Medinets
> > <david.medinets@gmail.com>wrote:
> >
> >> 2012-10-16 03:44:57,546 [server.TThreadPoolServer] ERROR: Error
> >> occurred during processing of message.
> >> java.lang.NullPointerException
> >>         at
> >> org.apache.thrift.ProcessFunction.process(ProcessFunction.java:34)
> >>         at
> org.apache.thrift.TBaseProcessor.process(TBaseProcessor.java:34)
> >>         at
> >>
> org.apache.thrift.server.TThreadPoolServer$WorkerProcess.run(TThreadPoolServer.java:176)
> >>         at
> >>
> java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
> >>         at
> >>
> java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
> >>         at java.lang.Thread.run(Thread.java:679)
> >>
> >> I don't see anyway to debug the underlying issue but I'm posting this
> >> here just in case someone else does.
> >>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message