accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Newton <eric.new...@gmail.com>
Subject Re: Internal Metadata scan timeouts
Date Wed, 22 Aug 2012 18:30:18 GMT
The Repo should probably switch to shutdown mode when you have only one
tserver.  However, it's a little surprising that your master goes into
"clean shutdown" mode when you ask for one server to go offline.

I wouldn't bother with a new ticket.  Its not an issue for 1.5 and it's a
silly case.

-Eric

On Wed, Aug 22, 2012 at 11:28 AM, John Vines <vines@apache.org> wrote:

> I bumped into a bug with ACCUMULO-676, which has to do with offlining a
> tserver & logger on a single node instance. Specifically, they get jammed
> up on a scan of the !METADATA table to ensure that nothing else still needs
> the logger ( http://pastebin.com/m8Q3ZTTn ). There's a quick fix there
> which is to not do the !METADATA check if there are no tservers. But this
> leads to a slightly larger potential issue of !METADATA scans failing
> perpetually with no oppertunity for error handling. There are some
> instances where you want to do retries. But at some point, the error needs
> to be kicked back to a higher level for it to handle (whether or not it
> retries immediately is up to the specific case).
>
> However, this seems like something that would have been broached before, so
> perhaps there is some reasoning for it here that I'm overlooking. Any
> thoughts before I open up a gargantuan ticket to broach this subject?
>
> John
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message