accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Initialized But No /accumulo/instance_id was created in Zookeeper
Date Mon, 11 Jun 2012 01:58:56 GMT
I deleted /accumulo from HDFS. I ran "ls /" in Zookeeper and did not
see /accumulo. So I ran the 'accumulo init' program. No errors.

Then I ran ZooZap with the verbose option and got this error:

12/06/10 21:57:06 ERROR client.ZooKeeperInstance: unable obtain
instance id at /accumulo/instance_id
Exception in thread "main" java.lang.RuntimeException: Accumulo not
initialized, there is no instance id at /accumulo/instance_id
	at org.apache.accumulo.core.client.ZooKeeperInstance.getInstanceIDFromHdfs(ZooKeeperInstance.java:263)
	at org.apache.accumulo.server.client.HdfsZooInstance._getInstanceID(HdfsZooInstance.java:123)
	at org.apache.accumulo.server.client.HdfsZooInstance.getInstanceID(HdfsZooInstance.java:116)
	at org.apache.accumulo.server.util.ZooZap.main(ZooZap.java:67)

Has something changed in how the accumulo information is stored in Zookeeper?

Looking at Zookeeper, I now see:

[zk: 127.0.0.1:2181(CONNECTED) 1] ls /
[accumulo, zookeeper]
[zk: 127.0.0.1:2181(CONNECTED) 2] ls /accumulo
[2b64e012-a197-4ec0-a487-dc2e154cbd94, instances]
[zk: 127.0.0.1:2181(CONNECTED) 3] ls /accumulo/instances
[development]
[zk: 127.0.0.1:2181(CONNECTED) 4] ls /accumulo/instances/development
[]
[zk: 127.0.0.1:2181(CONNECTED) 5] ls
/accumulo/2b64e012-a197-4ec0-a487-dc2e154cbd94
[tables, tservers, users, problems, next_file, root_tablet,
hdfs_reservations, tracers, gc, table_locks, config, masters]

Mime
View raw message