accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Re: Need help getting Accumulo running.
Date Fri, 29 Jun 2012 23:37:03 GMT
oh... I think you missed a few steps from the gist:

$ cd ~
$ export TAR_DIR=~/workspace/accumulo/src/assemble/target
$ tar xvzf $TAR_DIR/accumulo-1.5.0-incubating-SNAPSHOT-dist.tar.gz

# Add the following to your .bashrc file.
$ export ACCUMULO_HOME=~/accumulo-1.5.0-incubating-SNAPSHOT

$ cd $ACCUMULO_HOME/conf

These are the steps where you unpack the newly-created gz file into
your home directory. It seems like you are running Accumulo from the
source code directory. Also notice that I wrote those steps for v1.5.0
which might be different from v1.4.0

On Fri, Jun 29, 2012 at 2:58 PM, Miguel Pereira
<miguelapereira1@gmail.com> wrote:
> Hi Jee,
>
> I used that same guide to install Accumulo, but I used this guide to
> install hadoop.
>
> http://www.michael-noll.com/tutorials/running-hadoop-on-ubuntu-linux-single-node-cluster/
>
> furthermore here are the steps I took to install accumulo were I used
> version 1.4.0 and standalone conf.
> please note you also need to install java jdk, and set your JAVA_HOME i
> used jdk 1.7
>
> Setting up Accumulo
>
>
>   - git clone     git://github.com/apache/accumulo.git
>   - cd accumulo
>   - git checkout     tags/1.4.0 -b 1.4.0
>   - mvn package && mvn assembly:single -N.             // this can take
a
>   while
>   - cp conf/examples/512MB/standalone/* conf
>   - vi accumulo-env.sh
>
>
> test -z "$JAVA_HOME" && export JAVA_HOME=/home/hduser/pkg/jdk1.7.0_04
> test -z "$HADOOP_HOME" && export
> HADOOP_HOME=/home/hduser/developer/workspace/hadoop
> test -z "$ZOOKEEPER_HOME" && export
> ZOOKEEPER_HOME=/home/hduser/developer/workspace/zookeeper-3.3.5
>
>   - vi     accumulo-site.xml
>
>
>    modify user, password, secret, memory
>
>
>   - bin/accumulo     init
>   - bin/start-all.sh
>   - bin/accumulo     shell -u root
>
> if you get the shell up you know your good.
>
>
> On Fri, Jun 29, 2012 at 2:49 PM, John Vines <john.w.vines@ugov.gov> wrote:
>
>> We currently don't really support running on Windows. I'm sure there are
>> ways to get it running with Cygwin, but our efforts are better spend in
>> other directions for now.
>>
>> As for getting it going in Ubuntu, I haven't seen that guide before. Can
>> you let me know where it broke?
>>
>> For the record, when I was developing ACCUMULO-404, I was working in Ubuntu
>> VMs and I used Apache-BigTop and our debians to facilitate installation.
>> They don't do everything for you, but I think if you use 1.4.1 (not sure if
>> I got the debs into 1..4.0), it should diminish the installation work you
>> must do to some minor configuration.
>>
>> John
>>
>> On Fri, Jun 29, 2012 at 2:28 PM, Park, Jee [USA] <Park_Jee@bah.com> wrote:
>>
>> > Hi, ****
>> >
>> > ** **
>> >
>> > I had trouble getting Accumulo to work on a VM instance of Ubuntu (11.04)
>> > using this guide: https://gist.github.com/1535657.****
>> >
>> > Does anyone have a step-by-step guide to get it running on either Ubuntu
>> > or Windows 7?****
>> >
>> > ** **
>> >
>> > Thanks!****
>> >
>>

Mime
View raw message