accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kristopher Blair (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-648) init process hangs after entering instance name
Date Wed, 20 Jun 2012 15:09:44 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-648?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13397574#comment-13397574
] 

Kristopher Blair commented on ACCUMULO-648:
-------------------------------------------

My NameNode and JobTracker don't startup, then my DataNode fails due to not being able to
connect to the NameNode.

It is Cloudbase 1.3.4, but my understanding is that they are the same project.

My variables are set. I think the problems with my Hadoop are the root cause of my Cloudbase/Accumulo
problems.

Would you know anything about Hadoop errors ?

The logs say the same exception for both the NameNode and JobTracker:

FATAL org.apache.hadoop.mapred.JobTracker: java.net.BindException: Address already in use

and 

ERROR org.apache.hadoop.hdfs.server.namenode.NameNode: java.net.BindException: Address already
in use

I've changed my configured port around repeatedly, I've killed all java processes, I've tried
starting the dameons up individually, I've tried whatever is on the port just before attempting
to start it up...... nothing seems to work. I was using Hadoop 0.20.2, but I deleted that
and installed Hadoop 0.20.203.0.

I know this isn't the right forum for Hadoop, but if you have any suggestions it would be
appreciated.


                
> init process hangs after entering instance name
> -----------------------------------------------
>
>                 Key: ACCUMULO-648
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-648
>             Project: Accumulo
>          Issue Type: Bug
>          Components: scripts
>         Environment: Running Ubuntu 12.04
> Running Hadoop 0.20.2
> Running Zookeeper 3.4.3
> Running Accumulo 1.3.4
>            Reporter: Kristopher Blair
>            Assignee: John Vines
>            Priority: Blocker
>              Labels: accumulo, hangs, init
>
> I start zookeeper with zoo-start.sh
> I can get to the zookeeper command line with zkCli.sh
> However, I run accumulo.sh init and then enter an instance name of kgbCloudbase
> the init then hangs indefinitely.
> I've went into the conf folder and granted 
> permission java.security.AllPermission;
> Can anybody help debug why this is hanging ?

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message