accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Pine (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-601) Cannot create or delete tables via Java after upgrade to accumulo 1.4
Date Mon, 21 May 2012 21:27:41 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-601?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13280517#comment-13280517
] 

Steven Pine commented on ACCUMULO-601:
--------------------------------------

I wanted to pass on my further testing for completness.

I still have not been able to resolve this problem. It still hangs during the create or delete
from my workstation it doesn't matter whether I run this inside eclipse or from the command
line. 

I Tested the following: 

Server Side (Linux): 
1. Ran my java source code on the Server and it works. 
2. I Generated a jar via Eclipse (after dumb-ing it down to 1.6 jre) and it also ran fine
on the Server. 

Workstation side (Windows): 
1. Running the java source via Eclipse hangs at the create line of the code.
2. Running the jar from the Windows command line also hangs at the create line. 

Note: I re-copied the jar files from the server to the Workstation just to ensure that I was
running with the exact same jar files. 

This narrows down my ideas to two possibilities: 

1. Some Firewall rule is intercepting traffic so that it hangs and never completes (however
I can Scan and perform mutation on tables from my workstation). 
2. There is some kind of dependency be it Linux or some object on the Server that the create/delete
class depends on that is not there in Windows. 

Note: Keeping in mind that I can run java code to scan and perform mutations against Accumulo
tables and they work fine from within Eclipse (on my Workstation)leads me to lean more towards
option 2 (unless there is some specific traffic that occurs when creating/deleting tables
that does not occur when you scan or perform mutations).

                
> Cannot create or delete tables via Java after upgrade to accumulo 1.4
> ---------------------------------------------------------------------
>
>                 Key: ACCUMULO-601
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-601
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.0
>         Environment: Cloud was upgraded from Cloudbase 1.3.4 to Accumulo 1.3.5 and then
upgraded to accumulo 1.4.0. Hadoop version is 0.20.2r911707
>            Reporter: Steven Pine
>            Assignee: Billie Rinaldi
>
> After upgrade I am unable to create or delete a table via java using either the 
> conn.tableOperations().delete(tableName); 
> and/or 
> conn.tableOperations().create(tableName);
> The error presents itself by hanging the code when it executes this line in the code.

> Important:
> Table scans via java are working fine.
> Table mutations via java also work fine. 
> The same user account can create and deleted the table via accumulo shell. 
> The cause of the code hanging cannot be determined further since there is nothing in
the Eclipse logs or Server logs that provide any more information. 
> I can verify that the connection to Zookeeper completes successfully... however there
is no indication after that on the Server side that a call is being made to Accumulo to create/delete
the table.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message