accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject RE: Windows/Intell-J
Date Tue, 29 May 2012 14:21:12 GMT

Thanks for your time/input.  I have my VM up and running with RHEL 6.
No issues there.  What I'm asking is about building the accumulo targets
from a pure Windows platform such that accumulo-*-SNAPSHOT-dist.tar.gz
can be generated from IntelliJ (in my case).  I can get it built with
major modifications to the build scripts (i.e.
trunk/docs/src/user_manual/ to work on Windows 7 using cygwin,
pdflatex, etc.  Once I got past this script there are others to work on.
I just didn't want to go through this without the dev community support.

-----Original Message-----
From: Michael Van Geertruy [] 
Sent: Thursday, May 24, 2012 00:01
Subject: Re: Windows/Intell-J


One other thing. The Vapp I built had hadoop in it, but it also
contained Accumulo (and Hmap, zookeeper, etc).  To get everything
working inside of 6 gigs, I needed to do a lot of tweaking that brought
many of the applications below thier suggested minimum ram requirements.

The key was to make sure that xms + MaxPerSize of all the technologies
together did not exceed 5 gigs (i left one gig for CentOS, although you
should be fine with 512megs). It is absolutely imperative that you have
both of those settings set for each application, or you could run out of
memory as the various applications begin to consume more ram than you
originally allocated. Unless you're doing something other than
prototyping something simple or just demoing the technologies, you
should be fine using less ram.

On 5/24/2012 12:50 AM, Michael Van Geertruy wrote:
> Bob,
> I tried to do the same thing last October. Accumulo itself isn't the 
> problem when it comes to getting it to work on Windows. The problem is

> all the other applications that Accumulo relies on to work. For 
> example, I was unable to find a good port of hadoop, or hmap. All of 
> these applications were written with a target of linux/mac.  So, I 
> eventually abandoned the idea.
> Instead, I downloaded the free VMWare VMPlayer, installed Cent-OS into

> it and just deployed the entire suite of products Hadoop uses into 
> that.  (This process is called building a virtual appliance.) My 
> laptop was a very inexpensive one (RIP), all I did was upgrade the ram

> to 8 gigs, reserving 6 Gigs for VMWare and my virtual appliance.  All 
> of the components I list above are open-source. The only sticky thing 
> was that Oracles JDK license doesn't allow you to package it into a 
> Virtual appliance that your'e going to distribute. So, as long as 
> you're not going to sell the pre-configured VApp, you should be fine 
> using the Oracle JDK.
> Hope that help!
> Mike Van
> Committer - Apache Software Foundation
> On 5/23/2012 12:17 PM, wrote:
>> I downloaded the trunk on my Windows 7 machine and imported it into 
>> IntelliJ with complete success.  The maven targets were all available

>> but when I tried to build the build scripts failed trying to build 
>> the user's manual.
>> I have all the components to run the scripts and the PDF builder, but

>> the evaluation in the build script fail (obviously because they were 
>> built for a Unix shell).
>> Is the ability to build this in a Windows environment something 
>> anyone has accomplished?  Is it desired?
>> Bob Thorman
>> Engineering Fellow
>> L-3 Communications, ComCept
>> 1700 Science Place
>> Rockwall, TX 75032
>> (972) 772-7501 work

View raw message