accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steven Pine (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ACCUMULO-601) Cannot create or delete tables via Java after upgrade to accumulo 1.4
Date Wed, 23 May 2012 14:22:40 GMT

    [ https://issues.apache.org/jira/browse/ACCUMULO-601?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13281627#comment-13281627
] 

Steven Pine commented on ACCUMULO-601:
--------------------------------------

I tested changing conf/masters first using the IP address. That fixed it but as A side note
zookeeper had the <fully qualified hostname>:9999 stored.

I also tested placing the <fully qualified hostname> into conf/masters. That also worked.
During the first startup I got and RSA message "The authenticity pf host ..... can't be established"
message and accepted it the first time. Subsequent starts no longer prompted and everything
appears to be working normally. The value stored in zookeeper was also <fully qualified
hostname>:9999. 

Not sure why (when I put the IP Address in conf/masters) the IP address was converted to the
<fully qualified hostname> in zookeeper instead of keeping the IP Address.

The question is whether it would be better to let it store the IP Address (making it more
consistent with other zookeeper entries) and this might work better in cases where these type
of tasks want to be handled via remote administration. 

For now we have a workaround which is to either place the IP Address or since it doesn't matter
put the fully qualified hostname into conf/masters.
                
> Cannot create or delete tables via Java after upgrade to accumulo 1.4
> ---------------------------------------------------------------------
>
>                 Key: ACCUMULO-601
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-601
>             Project: Accumulo
>          Issue Type: Bug
>          Components: client
>    Affects Versions: 1.4.0
>         Environment: Cloud was upgraded from Cloudbase 1.3.4 to Accumulo 1.3.5 and then
upgraded to accumulo 1.4.0. Hadoop version is 0.20.2r911707
>            Reporter: Steven Pine
>            Assignee: Billie Rinaldi
>
> After upgrade I am unable to create or delete a table via java using either the 
> conn.tableOperations().delete(tableName); 
> and/or 
> conn.tableOperations().create(tableName);
> The error presents itself by hanging the code when it executes this line in the code.

> Important:
> Table scans via java are working fine.
> Table mutations via java also work fine. 
> The same user account can create and deleted the table via accumulo shell. 
> The cause of the code hanging cannot be determined further since there is nothing in
the Eclipse logs or Server logs that provide any more information. 
> I can verify that the connection to Zookeeper completes successfully... however there
is no indication after that on the Server side that a call is being made to Accumulo to create/delete
the table.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message