accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject "Waiting for accumulo to be initialized" message
Date Sun, 11 Mar 2012 13:39:15 GMT
I'm working on a ubuntu laptop. After a shutdown, I need to restart
hadoop, zookeeper and accumulo. How does the information about an
existing accumulo  get into the new zookeeper instance? I may not be
explaining this correctly. Let me describe the situation.

1. Hadoop is running. Both NameNode and JobTracker web pages are
working. I can also see the /accumulo and /hadoop_tmp_dir in hdfs.

2. Zookeeper is running. I can start the client, save a record, see
the record, and delete it.

3. bin/accumulo init claims this location was previously initialized.

  11 09:28:32,366 [util.Initialize] INFO : Hadoop Filesystem is
hdfs://localhost:9000
  11 09:28:32,369 [util.Initialize] INFO : Accumulo data dir is /accumulo
  11 09:28:32,369 [util.Initialize] INFO : Zookeeper server is localhost:2181
  11 09:28:32,462 [util.Initialize] FATAL: It appears this location
was previously initialized, exiting ..

4. Then I try to start accumulo:

medined@bashi:~/accumulo-1.5.0-incubating-SNAPSHOT$ bin/start-all.sh
Starting tablet servers and loggers .... done
Starting tablet server on localhost
Starting logger on localhost
11 09:34:45,970 [server.Accumulo] INFO : Attempting to talk to zookeeper
11 09:34:46,699 [server.Accumulo] INFO : Waiting for accumulo to be initialized
11 09:34:47,700 [server.Accumulo] INFO : Waiting for accumulo to be initialized
11 09:34:48,701 [server.Accumulo] INFO : Waiting for accumulo to be initialized
^CStarting master on localhost
Starting garbage collector on localhost
Starting monitor on localhost
Starting tracer on localhost

---

What am I doing wrong? Or not doing right?

Mime
View raw message