accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject Re: Message To Use ${project.artifactId} instead of ${artifactId} in pom.xml
Date Thu, 01 Mar 2012 05:07:37 GMT
https://issues.apache.org/jira/browse/ACCUMULO-437 covers this issue.

On Wed, Feb 29, 2012 at 11:38 PM, John Vines <john.w.vines@ugov.gov> wrote:
> They should be switched. I didn't see them due to the other maven warnings
> in 1.4, and I didn't look at the messages that hard for 1.5. Except that
> info shouldn't be in the base pom, so I think I might have merged
> incorrectly. I'll take a look at it first thing in the morning.
>
> John
>
> On Wed, Feb 29, 2012 at 9:41 PM, David Medinets <david.medinets@gmail.com>wrote:
>
>> I am seeing the following warning:
>>
>> [WARNING] Some problems were encountered while building the effective
>> model for
>> org.apache.accumulo:accumulo-assemble:pom:1.5.0-incubating-SNAPSHOT
>> [WARNING] The expression ${artifactId} is deprecated. Please use
>> ${project.artifactId} instead.accumulo-assemble:pom
>>
>> In pom.xml, I see the following:
>>
>>  215:
>> <deb>${project.build.directory}/${artifactId}_${project.version}.deb</deb>
>>  310:
>> <deb>${project.build.directory}/${artifactId}-native_${project.version}-${os.arch}.deb</deb>
>>  350:
>> <deb>${project.build.directory}/${artifactId}-test_${project.version}-${os.arch}.deb</deb>
>>
>> In src/assemble/pom.xml, I see the following lines:
>>
>>  269:
>> <deb>${project.build.directory}/${artifactId}_${project.version}.deb</deb>
>>  364:
>> <deb>${project.build.directory}/${artifactId}-native_${project.version}-${os.arch}.deb</deb>
>>  404:
>> <deb>${project.build.directory}/${artifactId}-test_${project.version}-${os.arch}.deb</deb>
>>
>> Is there any reason, I should not change follow the advice of the warning?
>>

Mime
View raw message