accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Medinets <david.medin...@gmail.com>
Subject weak maven fu
Date Tue, 13 Mar 2012 03:01:15 GMT
As an experiment, I have rejiggered the project's root directory
hierarchy to be have these modules:

  module_assemble
  module_core
  module_example_simple
  module_server
  module_start
  module_trace
  module_wikisearch_ingest
  module_wikisearch_query
  module_wikisearch_query-war

With minor changes to the pom.xml, the start and trace sub-projects
package and install fine.However, the core module is kicking my butt.
For some reason, maven is looking at repository.apache.org/snapshots.
Here are the lines:

Downloading: http://repository.apache.org/snapshots/org/apache/accumulo/accumulo/1.5.0-incubating-SNAPSHOT/maven-metadata.xml
Downloading: http://repository.apache.org/snapshots/org/apache/accumulo/accumulo/1.5.0-incubating-SNAPSHOT/accumulo-1.5.0-incubating-SNAPSHOT.pom

[ERROR] Failed to execute goal on project accumulo-core: Could not
resolve dependencies for project
org.apache.accumulo:accumulo-core:jar:1.5.0-incubating-SNAPSHOT:
Failed to collect dependencies for
[org.apache.hadoop:hadoop-core:jar:0.20.2 (provided),
org.apache.hadoop:zookeeper:jar:3.3.1 (provided),
log4j:log4j:jar:1.2.16 (compile), org.slf4j:slf4j-api:jar:1.4.3
(compile), org.slf4j:slf4j-log4j12:jar:1.4.3 (compile),
commons-collections:commons-collections:jar:3.2 (compile),
org.apache.thrift:libthrift:jar:0.6.1 (compile),
org.apache.accumulo:accumulo-start:jar:1.5.0-incubating-SNAPSHOT
(compile), org.apache.accumulo:cloudtrace:jar:1.5.0-incubating-SNAPSHOT
(compile), jline:jline:jar:0.9.94 (compile),
commons-lang:commons-lang:jar:2.4 (compile), junit:junit:jar:4.4
(test)]: Failed to read artifact descriptor for
org.apache.accumulo:accumulo-start:jar:1.5.0-incubating-SNAPSHOT:
Could not find artifact
org.apache.accumulo:accumulo:pom:1.5.0-incubating-SNAPSHOT in
apache.snapshots (http://repository.apache.org/snapshots) -> [Help 1]

I don't understand why start and trace compile but core does not. I
can't see any cause for the different behaviour in the sub-project pom
files.

Does anyone want to work on this with me? I don't know enough maven
arcana to figure this issue out.

Mime
View raw message