accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Newton <eric.new...@gmail.com>
Subject Re: Testing fix for ACCUMULO-476 on mapr
Date Fri, 23 Mar 2012 19:18:48 GMT
Actually, since we had a number of issues with 1.4.0 rc3, we pulled this
fix in.

-Eric

On Wed, Mar 21, 2012 at 9:18 AM, Eric Newton <eric.newton@gmail.com> wrote:

> Sorry, not until 1.4.1.
>
> -Eric
>
>
> On Wed, Mar 21, 2012 at 9:14 AM, Todd Stavish <toddstavish@gmail.com>wrote:
>
>> Hi Eric,
>>
>> > There's an option to have the tablet server search for a port to use:
>> >
>> > <property>
>> >  <name>tserver.port.search</name>
>> >  <value>true</value>
>> > </property>
>>
>> Oh, nice.
>>
>> > You must have had something using port 9997, perhaps you need to run
>> > netstat as root to see it?
>>
>> After I switched ports, I grep'd the netstat output and sure enough
>> 9997 was being used. I don't know how I missed it (multiple times).
>>
>> > The build script in src/assembly will build the native libs, but you
>> need
>> > C++ development tools installed (make, compiler, system headers, etc).
>>
>> Yep, that's probably it. I had to install mvn, svn into their VM. I
>> doubt it has the c++ dev stack. I'll try to do the full build, coping
>> libraries was an act of desperation.
>>
>> Will this fix go into 1.4rc branch?
>>
>> Thanks again,
>> -Todd
>>
>> >
>> > -Eric
>> >
>> > On Tue, Mar 20, 2012 at 10:20 PM, Todd Stavish <toddstavish@gmail.com
>> >wrote:
>> >
>> >> I got everything working. Accumlo runs on mapr!
>> >>
>> >> I mapped tserver.port.client to 9996 and copied the native libs from
>> rc2.
>> >>
>> >> -Todd
>> >>
>> >>
>> >>
>> >> On Tue, Mar 20, 2012 at 6:14 PM, Todd Stavish <toddstavish@gmail.com>
>> >> wrote:
>> >> > Hello,
>> >> >
>> >> > I checked out trunk. Everything seems to build, except the native
>> >> > libraries. I tried mvn-2.2.1: 'clean install,' 'compile,' 'package
-P
>> >> > assemble.'
>> >> >
>> >> > Questions:
>> >> >
>> >> > Do I need to run accumulo init again?
>> >> >
>> >> > Is it okay if I use my conf files from 1.4 rc2?
>> >> >
>> >> > I am also seeing failures on port 9997? According to netstat, nothing
>> >> > is on port 9997. Not sure if this is related to the library problem
>> or
>> >> > not.
>> >> >
>> >> > From Logs:
>> >> >
>> >> > Port 9997 ->
>> >> >
>> >> > 20 17:25:53,990 [util.TServerUtils] INFO : Unable to use port 9997,
>> >> > retrying. (Thread Name = Thrift Client Server)
>> >> >
>> >> >
>> >> > Missing lib ->
>> >> >
>> >> > 20 17:25:53,722 [tabletserver.NativeMap] ERROR: Failed to load native
>> >> > map library
>> >>
>> /opt/accumulo-1.4.0-incubating/lib/native/map/libNativeMap-Linux-amd64-64.so
>> >> > java.lang.UnsatisfiedLinkError: Can't load library:
>> >> >
>> >>
>> /opt/accumulo-1.4.0-incubating/lib/native/map/libNativeMap-Linux-amd64-64.so
>> >> >        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1706)
>> >> >        at java.lang.Runtime.load0(Runtime.java:770)
>> >> >        at java.lang.System.load(System.java:1003)
>> >> >        at
>> >>
>> org.apache.accumulo.server.tabletserver.NativeMap.loadNativeLib(NativeMap.java:144)
>> >> >        at
>> >>
>> org.apache.accumulo.server.tabletserver.NativeMap.<clinit>(NativeMap.java:156)
>> >> >        at
>> >>
>> org.apache.accumulo.server.tabletserver.TabletServerResourceManager.<init>(TabletServerResourceManager.java:123)
>> >> >        at
>> >>
>> org.apache.accumulo.server.tabletserver.TabletServer.config(TabletServer.java:2983)
>> >> >        at
>> >>
>> org.apache.accumulo.server.tabletserver.TabletServer.main(TabletServer.java:3109)
>> >> >        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> >> >        at
>> >>
>> sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> >> >        at
>> >>
>> sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
>> >> >        at java.lang.reflect.Method.invoke(Method.java:597)
>> >> >        at org.apache.accumulo.start.Main$1.run(Main.java:89)
>> >> >        at java.lang.Thread.run(Thread.java:662)
>> >> >
>> >> >
>> >> >
>> >> >
>> >> > Thanks,
>> >> > -Todd
>> >>
>>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message