accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Newton <>
Subject Re: Inconsistent Naming in IteratorSetting class.
Date Mon, 19 Mar 2012 14:18:31 GMT
I don't know why there are duplicate methods for the same concept.

I propose we add getOptions, and deprecate getProperties, setProperties,

And getOptions should return an unmodifiable map.

I disagree about the generic names; I like short names.  Eclipse finds
references pretty well.


On Sun, Mar 18, 2012 at 7:25 PM, David Medinets <>wrote:

> A Property object used to hold key-value information used to modify
> the behavior of an Interator. However, these are the methods
> available:
>  getProperties
>  setProperties
>  hasProperties
>  addOption
>  removeOption
>  addOptions
>  clearOptions
> Is there a reason why the same concept as two names? I'd like to
> settle on one name and standardise.
> Could we change the names to be something like
> getInteratorSettingProperties? I know that some people are annoyed by
> longer method names, but when searching through a code base, have
> unique names is handy. Searching for a generically named method - such
> as getProperties, returns a lot of false positives.
> Is there a list (or example) of supported properties? For example, I
> see the following options when I type 'help setiter'. How are these
> options defined in code?
>  -ageoff,--ageoff                 an aging off type
>  -agg,--aggregator                an aggregating type
>  -majc,--major-compaction         applied at major compaction
>  -minc,--minor-compaction         applied at minor compaction
>  -regex,--regular-expression      a regex matching type
>  -reqvis,--require-visibility     a type that omits entries with
> empty visibilities
>  -scan,--scan-time                applied at scan time
>  -vers,--version                  a versioning type

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message