accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jesse Yates (Assigned) (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (ACCUMULO-80) Refactor ScannerOptions to just use a map of iterators
Date Wed, 28 Mar 2012 19:03:28 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-80?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Jesse Yates reassigned ACCUMULO-80:
-----------------------------------

    Assignee:     (was: Jesse Yates)

Don't have time to pursue this implementation - someone else should pick it up if they are
so inclined.
                
> Refactor ScannerOptions to just use a map of iterators
> ------------------------------------------------------
>
>                 Key: ACCUMULO-80
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-80
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client, tserver
>            Reporter: Jesse Yates
>             Fix For: 1.5.0
>
>
> Based on comments in ACCUMULO-53 ScannerOptions should be refactored to just having a
Map<String, IteratorSetting> mapping iterator names to iterator settings, instead of
a list and a map<scope, options>. This makes it really easy for people to add/remove
iterators.
> This involves a change to the thrift interface as well as in ScannerBase and the server
side reading of the map. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message