accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (Commented) (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-498) Key.getColumnVisibility() should return a ColumnVisibility, not a Text
Date Wed, 28 Mar 2012 18:53:28 GMT


Keith Turner commented on ACCUMULO-498:

This was probably done because creating a ColumnVisibility object is expensive, it creates
a parse tree and verifies the expression is correct.  If all you want to do is copy the visibility
from one key to another, then this would be a lot of overhead.  Also, I do not think the return
type on the current method could be changed because the return type is not part of the signature.
Would need to create a new method name and deprecate the old one.
> Key.getColumnVisibility() should return a ColumnVisibility, not a Text
> ----------------------------------------------------------------------
>                 Key: ACCUMULO-498
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>    Affects Versions: 1.3.5, 1.4.0
>            Reporter: John Vines
>            Priority: Trivial
>              Labels: newbie
>             Fix For: 1.5.0
> Currently getColumnVisibility() returns a Text. This doesn't make a lot of sense, since
all other methods dealing with column visibilities use the ColumnVisibility object. We should
use that instead.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message