accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Billie Rinaldi (Commented) (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-477) inconsistent names and duplicate methods in IteratorSettings
Date Wed, 21 Mar 2012 13:55:40 GMT


Billie Rinaldi commented on ACCUMULO-477:

What does deprecated since 1.4.1 imply?  Does that mean we would remove the methods in 1.5?

Also, the javadocs are incorrect.  Syntax for methods is Classname#methodName (or just #methodName
if it's the current class), and there's a link to a method that doesn't exist (setOptions
presumably should be addOptions).
> inconsistent names and duplicate methods in IteratorSettings 
> -------------------------------------------------------------
>                 Key: ACCUMULO-477
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: David Medinets
>            Assignee: Eric Newton
>            Priority: Trivial
>             Fix For: 1.4.1
> David Medinets noticed
> {quote}
> A Property object used to hold key-value information used to modify
> the behavior of an Interator. However, these are the methods
> available:
> {noformat}
>  getProperties
>  setProperties
>  hasProperties
>  addOption
>  removeOption
>  addOptions
>  clearOptions
> {noformat}
> Is there a reason why the same concept as two names? I'd like to
> settle on one name and standardise.
> Could we change the names to be something like
> getInteratorSettingProperties? I know that some people are annoyed by
> longer method names, but when searching through a code base, have
> unique names is handy. Searching for a generically named method - such
> as getProperties, returns a lot of false positives.
> {quote}

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message