accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Accumulo-Trunk » accumulo-assemble #265
Date Tue, 13 Mar 2012 22:29:10 GMT
See <https://builds.apache.org/job/Accumulo-Trunk/org.apache.accumulo$accumulo-assemble/265/changes>

Changes:

[bimargulies] ACCUMULO-464: also pick up assembly descriptor.

[bimargulies] ACCUMULO-464: sort out pathnames in assemble.

------------------------------------------
[JENKINS] cobertura-maven-plugin already configured with xml reports enabled
[INFO] 
[INFO] --- cobertura-maven-plugin:2.5.1:cobertura (default-cli) @ wikisearch-query-war ---
[JENKINS] Archiving /home/jenkins/jenkins-slave/workspace/Accumulo-Trunk/accumulo-trunk/examples/wikisearch/query-war/target/wikisearch-query-war-1.5.0-incubating-SNAPSHOT.war
to /home/hudson/hudson/jobs/Accumulo-Trunk/modules/org.apache.accumulo$wikisearch-query-war/builds/2012-03-13_22-01-49/archive/org.apache.accumulo/wikisearch-query-war/1.5.0-incubating-SNAPSHOT/wikisearch-query-war-1.5.0-incubating-SNAPSHOT.war
[INFO] Downloading: http://repo1.maven.org/maven2/org/eclipse/m2e/lifecycle-mapping/1.0.0/lifecycle-mapping-1.0.0.pom
                                                                        
[INFO] ------------------------------------------------------------------------
[INFO] Building accumulo-assemble 1.5.0-incubating-SNAPSHOT
[INFO] ------------------------------------------------------------------------
[WARNING] The POM for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0 is missing, no dependency
information available
[WARNING] Failed to retrieve plugin descriptor for org.eclipse.m2e:lifecycle-mapping:1.0.0:
Plugin org.eclipse.m2e:lifecycle-mapping:1.0.0 or one of its dependencies could not be resolved:
Failed to read artifact descriptor for org.eclipse.m2e:lifecycle-mapping:jar:1.0.0
[INFO] [INFO] Deleting <https://builds.apache.org/job/Accumulo-Trunk/org.apache.accumulo$accumulo-assemble/ws/>
(includes = [**/*.pyc], excludes = [])

[INFO] --- maven-clean-plugin:2.4.1:clean (default-clean) @ accumulo-assemble ---
[INFO] 
[INFO] --- maven-enforcer-plugin:1.0.1:enforce (enforce-mvn) @ accumulo-assemble ---
[INFO] 
[INFO] --- maven-remote-resources-plugin:1.2.1:process (default) @ accumulo-assemble ---
[INFO] 
[INFO] --- maven-dependency-plugin:2.3:copy-dependencies (copy-dependencies) @ accumulo-assemble
---
[INFO] Missing pdflatex command. Please install.

[INFO] --- exec-maven-plugin:1.2:exec (user-manual) @ accumulo-assemble ---
[INFO] 
[INFO] --- maven-site-plugin:3.0:attach-descriptor (attach-descriptor) @ accumulo-assemble
---
[INFO] 
[INFO] --- exec-maven-plugin:1.2:exec (config webpage) @ accumulo-assemble ---
Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/log4j/Logger
	at org.apache.accumulo.core.conf.AccumuloConfiguration.<clinit>(AccumuloConfiguration.java:29)
Caused by: java.lang.ClassNotFoundException: org.apache.log4j.Logger
	at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:247)
	... 1 more
Could not find the main class: org.apache.accumulo.core.conf.DefaultConfiguration.  Program
will exit.
[JENKINS] Archiving <https://builds.apache.org/job/Accumulo-Trunk/org.apache.accumulo$accumulo-assemble/ws/pom.xml>
to /home/hudson/hudson/jobs/Accumulo-Trunk/modules/org.apache.accumulo$accumulo-assemble/builds/2012-03-13_22-01-49/archive/org.apache.accumulo/accumulo-assemble/1.5.0-incubating-SNAPSHOT/accumulo-assemble-1.5.0-incubating-SNAPSHOT.pom


Mime
View raw message