accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eric Newton (Commented) (JIRA)" <>
Subject [jira] [Commented] (ACCUMULO-477) inconsistent names and duplicate methods in IteratorSettings
Date Tue, 20 Mar 2012 17:37:37 GMT


Eric Newton commented on ACCUMULO-477:

I responded:

I don't know why there are duplicate methods for the same concept.

I propose we add getOptions, and deprecate getProperties, setProperties, hasProperties.

And getOptions should return an unmodifiable map.

I disagree about the generic names; I like short names.  Eclipse finds references pretty well.

> inconsistent names and duplicate methods in IteratorSettings 
> -------------------------------------------------------------
>                 Key: ACCUMULO-477
>                 URL:
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: David Medinets
>            Assignee: Eric Newton
>            Priority: Trivial
>             Fix For: 1.4.1
> David Medinets noticed
> {quote}
> A Property object used to hold key-value information used to modify
> the behavior of an Interator. However, these are the methods
> available:
> {noformat}
>  getProperties
>  setProperties
>  hasProperties
>  addOption
>  removeOption
>  addOptions
>  clearOptions
> {noformat}
> Is there a reason why the same concept as two names? I'd like to
> settle on one name and standardise.
> Could we change the names to be something like
> getInteratorSettingProperties? I know that some people are annoyed by
> longer method names, but when searching through a code base, have
> unique names is handy. Searching for a generically named method - such
> as getProperties, returns a lot of false positives.
> {quote}

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


View raw message