accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Keith Turner (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (ACCUMULO-477) inconsistent names and duplicate methods in IteratorSettings
Date Wed, 21 Mar 2012 21:08:38 GMT

     [ https://issues.apache.org/jira/browse/ACCUMULO-477?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Keith Turner updated ACCUMULO-477:
----------------------------------

    Fix Version/s:     (was: 1.4.1)
                   1.4.0
    
> inconsistent names and duplicate methods in IteratorSettings 
> -------------------------------------------------------------
>
>                 Key: ACCUMULO-477
>                 URL: https://issues.apache.org/jira/browse/ACCUMULO-477
>             Project: Accumulo
>          Issue Type: Improvement
>          Components: client
>            Reporter: David Medinets
>            Assignee: Eric Newton
>            Priority: Trivial
>             Fix For: 1.4.0
>
>
> David Medinets noticed
> {quote}
> A Property object used to hold key-value information used to modify
> the behavior of an Interator. However, these are the methods
> available:
> {noformat}
>  getProperties
>  setProperties
>  hasProperties
>  addOption
>  removeOption
>  addOptions
>  clearOptions
> {noformat}
> Is there a reason why the same concept as two names? I'd like to
> settle on one name and standardise.
> Could we change the names to be something like
> getInteratorSettingProperties? I know that some people are annoyed by
> longer method names, but when searching through a code base, have
> unique names is handy. Searching for a generically named method - such
> as getProperties, returns a lot of false positives.
> {quote}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message