accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Billie J Rinaldi <billie.j.rina...@ugov.gov>
Subject Re: Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0:site
Date Fri, 09 Mar 2012 14:26:30 GMT
Drew Farris and I originally tried to use "mvn site" in the Jenkins builds.  We couldn't get
it to work, but I can't recall exactly why.  I think there was some new issue with it in Maven
3.  Also, I think the creation of the assemble module was partially to address the problems
we were having.  Perhaps the assemble module should be creating the javadocs?

Billie


----- Original Message -----
> From: "John Vines" <john.w.vines@ugov.gov>
> To: accumulo-dev@incubator.apache.org
> Sent: Thursday, March 8, 2012 9:43:51 AM
> Subject: Re: Failed to execute goal org.apache.maven.plugins:maven-site-plugin:3.0:site
> I've never used 'mvn site'. Is this something that we want/need to
> support?
> From a cursory glance, it's just for generating automated reports,
> right?
> 
> John
> 
> On Wed, Mar 7, 2012 at 11:33 PM, David Medinets
> <david.medinets@gmail.com>wrote:
> 
> > This website,
> > https://cwiki.apache.org/MAVEN/maven-3x-plugin-compatibility-matrix.html,
> > says that maven 3 needs the findbugs v2.3 plugin instead of 2.0.1.
> > So
> > I made that change (locally) and ran into this issue:
> >
> > [ERROR] Failed to execute goal
> > org.apache.maven.plugins:maven-site-plugin:3.0:site (default-site)
> > on
> > project accumulo: failed to get report for
> > org.apache.maven.plugins:maven-javadoc-plugin: Unable to parse
> > configuration of mojo
> > org.apache.maven.plugins:maven-javadoc-plugin:2.5:javadoc: Setter
> > org.apache.maven.plugin.javadoc.JavadocReport.setReportOutputDirectory(
> > java.io.File ) threw exception when called with parameter
> >
> > '/home/medined/Desktop/Dropbox/david/workspace/accumulo/target/site/apidocs':
> > null: InvocationTargetException: NullPointerException -> [Help 1]
> >
> > The directory in question (.../apidocs) did not exist. I created it
> > (just in case) and re-ran the command. But the same error happened.
> >
> > On Wed, Mar 7, 2012 at 11:22 PM, David Medinets
> > <david.medinets@gmail.com> wrote:
> > > I tried to execute 'mvn site' in the accumulo project. Should it
> > > work?
> > > This is the message I got:
> > >
> > > [ERROR] Failed to execute goal
> > > org.apache.maven.plugins:maven-site-plugin:3.0:site (default-site)
> > > on
> > > project accumulo: failed to get report for
> > > org.codehaus.mojo:findbugs-maven-plugin: Unable to parse
> > > configuration
> > > of mojo org.codehaus.mojo:findbugs-maven-plugin:2.0.1:findbugs for
> > > parameter localRepository: Abstract class or interface
> > > 'org.apache.maven.artifact.repository.DefaultArtifactRepository'
> > > cannot be instantiated -> [Help 1]
> > > [ERROR]
> > > [ERROR] To see the full stack trace of the errors, re-run Maven
> > > with
> > > the -e switch.
> > > [ERROR] Re-run Maven using the -X switch to enable full debug
> > > logging.
> > > [ERROR]
> > > [ERROR] For more information about the errors and possible
> > > solutions,
> > > please read the following articles:
> > > [ERROR] [Help 1]
> > > http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
> >

Mime
View raw message