accumulo-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John W Vines <john.w.vi...@ugov.gov>
Subject Re: errors during build
Date Wed, 26 Oct 2011 22:51:09 GMT
I'm not a maven expert either, but it looks as though maven failed to update itself. I suggest
you use the eclipse marketplace and make sure you have the most recent version downloaded.
I'm using m2e 1.0.100.* with the maven SCM version 0.13.0.* on eclipse Indigo. You may also
want to try uninstalling the plugin if there are no updates. Oh yeah, and make sure your connected
to a network when you build the first time as maven will downloaded dependencies and other
modules it needs to build.

Good Luck
John

----- Original Message -----
| From: "Ameet M. Kini" <akini@mitre.org>
| To: accumulo-dev@incubator.apache.org
| Sent: Wednesday, October 26, 2011 6:04:24 PM
| Subject: errors during build
| I'm new to Accumulo and Maven, and am trying to build from source as
| described here (http://incubator.apache.org/accumulo/source.html).
| This is on Windows 7. The error below is while running "mvn package",
| but separately I have tried building via the Eclipse m2e plugin and
| have encountered similar errors there too. The only step I differed
| from the online doc was that the source was fetched via the m2e
| "Checkout Maven Projects as SCM" instead of running "svn co" on the
| command line.
| 
| C:\Users\akini\workspace\accumulo>mvn package
| [INFO] Scanning for projects...
| [INFO] Reactor build order:
| [INFO] accumulo
| [INFO] cloudtrace
| [INFO] accumulo-start
| [INFO] accumulo-core
| [INFO] accumulo-server
| [INFO] accumulo-examples
| [INFO]
| ------------------------------------------------------------------------
| [INFO] Building accumulo
| [INFO] task-segment: [package]
| [INFO]
| ------------------------------------------------------------------------
| Downloading:
| http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-7/maven-site-plugin-2.0-beta-7.pom
| [WARNING] Unable to get resource
| 'org.apache.maven.plugins:maven-site-plugin:pom:2.0-beta-7' from
| repository central (http://repo1.maven.org/maven2): Error transferring
| file: Connection timed out: connect
| Downloading:
| http://repo1.maven.org/maven2/org/apache/maven/plugins/maven-site-plugin/2.0-beta-7/maven-site-plugin-2.0-beta-7.pom
| [WARNING] Unable to get resource
| 'org.apache.maven.plugins:maven-site-plugin:pom:2.0-beta-7' from
| repository central (http://repo1.maven.org/maven2): Error transferring
| file: Connection timed out: connect
| [INFO]
| ------------------------------------------------------------------------
| [ERROR] BUILD ERROR
| [INFO]
| ------------------------------------------------------------------------
| [INFO] Error building POM (may not be this project's POM).
| 
| 
| Project ID: org.apache.maven.plugins:maven-site-plugin
| 
| Reason: POM 'org.apache.maven.plugins:maven-site-plugin' not found in
| repository: Unable to download the artifact from any repository
| 
| org.apache.maven.plugins:maven-site-plugin:pom:2.0-beta-7
| 
| from the specified remote repositories:
| central (http://repo1.maven.org/maven2)
| 
| for project org.apache.maven.plugins:maven-site-plugin
| 
| 
| [INFO]
| ------------------------------------------------------------------------
| [INFO] For more information, run Maven with the -e switch
| [INFO]
| ------------------------------------------------------------------------
| [INFO] Total time: 43 seconds
| [INFO] Finished at: Wed Oct 26 16:54:18 EDT 2011
| [INFO] Final Memory: 5M/61M
| [INFO]
| ------------------------------------------------------------------------
| 
| -Ameet Kini

Mime
View raw message