accumulo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ktur...@apache.org
Subject [accumulo-maven-plugin] 01/01: Pointer to setting Accumulo, Hadoop, and ZK vers
Date Thu, 08 Aug 2019 17:29:34 GMT
This is an automated email from the ASF dual-hosted git repository.

kturner pushed a commit to branch keith-turner-patch-1
in repository https://gitbox.apache.org/repos/asf/accumulo-maven-plugin.git

commit d9aa6a88b8ef5a33a5eb2902edc27b4d25f8b0d2
Author: Keith Turner <kturner@apache.org>
AuthorDate: Thu Aug 8 13:29:30 2019 -0400

    Pointer to setting Accumulo, Hadoop, and ZK vers
---
 src/site/markdown/index.md.vm | 10 ++++++----
 1 file changed, 6 insertions(+), 4 deletions(-)

diff --git a/src/site/markdown/index.md.vm b/src/site/markdown/index.md.vm
index 8c0f5b3..ff20661 100644
--- a/src/site/markdown/index.md.vm
+++ b/src/site/markdown/index.md.vm
@@ -24,10 +24,11 @@ Description
   This version of the plugin uses
   `accumulo-minicluster-$context.get("accumulo.version")`. This version [can
   be overridden similar to overriding checkstyle versions][2] by a later 2.x
-  version. Because Accumulo follows [Semantic Versioning][3], and this plugin
-  limits itself to using only public API, this should work if you meet the
-  dependency requirements of that version (accumulo-minicluster-2.1.0 will
-  require Java 11, for example).
+  version. For an example of setting Accumulo, Hadoop, and Zookeeper versions
+  when using this plugin checkout [Fluo's pom][4].Because Accumulo follows 
+  [Semantic Versioning][3], and this plugin limits itself to using only public 
+  API, this should work if you meet the dependency requirements of that version
+  (accumulo-minicluster-2.1.0 will require Java 11, for example).
 
 Getting Started
 ---------------
@@ -73,3 +74,4 @@ so your project will have access to the running Accumulo instance during
the
 [1]: https://maven.apache.org/guides/introduction/introduction-to-the-lifecycle.html
 [2]: https://blog.sonatype.com/2008/04/how-to-override-a-plugins-dependency-in-maven/
 [3]: https://semver.org/spec/v2.0.0.html
+[4]: https://github.com/apache/fluo/blob/2fe8215d66a73ef44b399bd5aeb50a198c71be0f/pom.xml#L260


Mime
View raw message