accumulo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From ctubb...@apache.org
Subject [accumulo] 01/01: Merge branch '1.9' into 2.0
Date Tue, 30 Jul 2019 00:20:24 GMT
This is an automated email from the ASF dual-hosted git repository.

ctubbsii pushed a commit to branch 2.0
in repository https://gitbox.apache.org/repos/asf/accumulo.git

commit fc0f4723fe9502ff7b49b7d27c96abe398e66d71
Merge: 5a6481f 1704d79
Author: Christopher Tubbs <ctubbsii@apache.org>
AuthorDate: Mon Jul 29 20:05:34 2019 -0400

    Merge branch '1.9' into 2.0

 pom.xml      | 51 +++++----------------------------------------------
 test/pom.xml |  5 -----
 2 files changed, 5 insertions(+), 51 deletions(-)

diff --cc pom.xml
index bc9d69b,bc548a8..0988bba
--- a/pom.xml
+++ b/pom.xml
@@@ -122,18 -127,16 +122,19 @@@
      <failsafe.groups />
      <!-- surefire/failsafe plugin option -->
      <forkCount>1</forkCount>
-     <hadoop.version>3.1.1</hadoop.version>
 -    <hadoop.version>2.6.5</hadoop.version>
++    <hadoop.version>3.1.2</hadoop.version>
 +    <hk2.version>2.5.0</hk2.version>
      <htrace.hadoop.version>4.1.0-incubating</htrace.hadoop.version>
 -    <htrace.version>3.1.0-incubating</htrace.version>
 +    <htrace.version>3.2.0-incubating</htrace.version>
      <it.failIfNoSpecifiedTests>false</it.failIfNoSpecifiedTests>
 -    <!-- jetty 9.2 is the last version to support jdk less than 1.8 -->
 -    <jetty.version>9.2.26.v20180806</jetty.version>
 -    <maven.compiler.release>7</maven.compiler.release>
 -    <maven.compiler.source>1.7</maven.compiler.source>
 -    <maven.compiler.target>1.7</maven.compiler.target>
 -    <maven.plugin-version>3.0.5</maven.plugin-version>
 +    <jackson.version>2.9.9</jackson.version>
 +    <javax.el.version>3.0.1-b06</javax.el.version>
 +    <jaxb.version>2.3.0.1</jaxb.version>
 +    <jersey.version>2.28</jersey.version>
 +    <jetty.version>9.4.19.v20190610</jetty.version>
++    <maven.compiler.release>8</maven.compiler.release>
 +    <maven.compiler.source>1.8</maven.compiler.source>
 +    <maven.compiler.target>1.8</maven.compiler.target>
      <!-- surefire/failsafe plugin option -->
      <maven.test.redirectTestOutputToFile>true</maven.test.redirectTestOutputToFile>
      <powermock.version>2.0.2</powermock.version>
@@@ -1121,24 -841,22 +1111,6 @@@
                </rules>
              </configuration>
            </execution>
--          <execution>
-             <id>enforce-java-signatures</id>
 -            <id>enforce-hadoop-profile</id>
--            <goals>
--              <goal>enforce</goal>
--            </goals>
-             <phase>process-test-classes</phase>
--            <configuration>
--              <rules>
-                 <checkSignatureRule implementation="org.codehaus.mojo.animal_sniffer.enforcer.CheckSignatureRule">
-                   <signature>
-                     <groupId>org.codehaus.mojo.signature</groupId>
-                     <artifactId>java18</artifactId>
-                     <version>1.0</version>
-                   </signature>
-                 </checkSignatureRule>
 -                <requireProperty>
 -                  <property>hadoop.profile</property>
 -                  <regex>(2|3)</regex>
 -                  <regexMessage>You should specify the Hadoop profile by major Hadoop
generation, i.e. 2 or 3, not by a version number.
 -    Use hadoop.version to use a particular Hadoop version within that generation.</regexMessage>
 -                </requireProperty>
--              </rules>
--            </configuration>
--          </execution>
          </executions>
        </plugin>
        <plugin>
@@@ -1579,68 -1361,44 +1547,59 @@@
          <spotbugs.excludeFilterFile>src/main/spotbugs/exclude-filter.xml</spotbugs.excludeFilterFile>
        </properties>
      </profile>
 -    <!-- Active by default, build against Hadoop 2 -->
      <profile>
 -      <id>hadoop-default</id>
 -      <activation>
 -        <property>
 -          <name>!hadoop.profile</name>
 -        </property>
 -      </activation>
 -      <properties>
 -        <hadoop.profile>2</hadoop.profile>
 -        <hadoop.version>2.6.4</hadoop.version>
 -      </properties>
 -    </profile>
 -    <!-- Build against hadoop 2 explicitly -->
 -    <profile>
 -      <id>hadoop2</id>
 -      <activation>
 -        <property>
 -          <name>hadoop.profile</name>
 -          <value>2</value>
 -        </property>
 -      </activation>
 -      <properties>
 -        <hadoop.version>2.6.4</hadoop.version>
 -      </properties>
 +      <!-- This profile uses the google errorprone compiler to enforce use of the Override
 +      annotation where needed. Auto-generated code is not checked. -->
 +      <id>use-errorprone</id>
 +      <build>
 +        <plugins>
 +          <plugin>
 +            <groupId>org.apache.maven.plugins</groupId>
 +            <artifactId>maven-compiler-plugin</artifactId>
 +            <configuration>
 +              <compilerId>javac-with-errorprone</compilerId>
 +              <forceJavacCompilerUse>true</forceJavacCompilerUse>
 +              <compilerArgs>
 +                <arg>-XepDisableAllChecks</arg>
 +                <arg>-Xep:MissingOverride:ERROR</arg>
 +                <arg>-XepExcludedPaths:.*/(proto|thrift|generated-sources)/.*</arg>
 +              </compilerArgs>
 +            </configuration>
 +            <dependencies>
 +              <dependency>
 +                <groupId>com.google.errorprone</groupId>
 +                <artifactId>error_prone_core</artifactId>
 +                <version>2.3.1</version>
 +              </dependency>
 +              <dependency>
 +                <groupId>org.codehaus.plexus</groupId>
 +                <artifactId>plexus-compiler-javac-errorprone</artifactId>
 +                <version>2.8</version>
 +              </dependency>
 +            </dependencies>
 +          </plugin>
 +        </plugins>
 +      </build>
      </profile>
 -    <!-- Build against hadoop 3 explicitly -->
      <profile>
 -      <id>hadoop3</id>
 -      <activation>
 -        <property>
 -          <name>hadoop.profile</name>
 -          <value>3</value>
 -        </property>
 -      </activation>
 -      <properties>
 -        <hadoop.version>3.0.0</hadoop.version>
 -      </properties>
 +      <id>sec-bugs</id>
 +      <build>
 +        <plugins>
 +          <plugin>
 +            <groupId>com.github.spotbugs</groupId>
 +            <artifactId>spotbugs-maven-plugin</artifactId>
 +            <configuration>
 +              <plugins>
 +                <plugin>
 +                  <groupId>com.h3xstream.findsecbugs</groupId>
 +                  <artifactId>findsecbugs-plugin</artifactId>
 +                  <version>1.8.0</version>
 +                </plugin>
 +              </plugins>
 +            </configuration>
 +          </plugin>
 +        </plugins>
 +      </build>
      </profile>
-     <profile>
-       <id>jdk-release-flag</id>
-       <activation>
-         <jdk>[9,)</jdk>
-       </activation>
-       <properties>
-         <maven.compiler.release>8</maven.compiler.release>
-       </properties>
-     </profile>
    </profiles>
  </project>


Mime
View raw message