accumulo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From els...@apache.org
Subject [2/3] accumulo git commit: ACCUMULO-3338 Fixing classpath items for busbey.
Date Tue, 18 Nov 2014 17:27:29 GMT
ACCUMULO-3338 Fixing classpath items for busbey.


Project: http://git-wip-us.apache.org/repos/asf/accumulo/repo
Commit: http://git-wip-us.apache.org/repos/asf/accumulo/commit/7ccae952
Tree: http://git-wip-us.apache.org/repos/asf/accumulo/tree/7ccae952
Diff: http://git-wip-us.apache.org/repos/asf/accumulo/diff/7ccae952

Branch: refs/heads/master
Commit: 7ccae952c09095cbc3e6b72876244979a5492e75
Parents: 091f70c
Author: Josh Elser <elserj@apache.org>
Authored: Tue Nov 18 12:18:20 2014 -0500
Committer: Josh Elser <elserj@apache.org>
Committed: Tue Nov 18 12:18:20 2014 -0500

----------------------------------------------------------------------
 assemble/bin/bootstrap_config.sh          | 61 +++++++++++++++++++++++---
 assemble/conf/templates/accumulo-site.xml |  7 ++-
 2 files changed, 62 insertions(+), 6 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/accumulo/blob/7ccae952/assemble/bin/bootstrap_config.sh
----------------------------------------------------------------------
diff --git a/assemble/bin/bootstrap_config.sh b/assemble/bin/bootstrap_config.sh
index 8b18757..42b83ad 100755
--- a/assemble/bin/bootstrap_config.sh
+++ b/assemble/bin/bootstrap_config.sh
@@ -232,19 +232,23 @@ fi
 if [[ -z "${HADOOP_VERSION}" ]]; then
   echo
   echo "Choose the Apache Hadoop version:"
-  select HADOOP in 'Hadoop 1' 'Hadoop 2' ; do
+  select HADOOP in 'Hadoop 1' 'Hadoop 2' 'HDP 2.0/2.1' 'HDP 2.2' ; do
     if [ "${HADOOP}" == "Hadoop 2" ]; then
       HADOOP_VERSION="2"
     elif [ "${HADOOP}" == "Hadoop 1" ]; then
       HADOOP_VERSION="1"
+    elif [ "${HADOOP}" == "HDP 2.0/2.1" ]; then
+      HADOOP_VERSION="HDP2"
+    elif [ "${HADOOP}" == "HDP 2.2" ]; then
+      HADOOP_VERSION="HDP2.2"
     fi
-    echo "Using Apache Hadoop version '${HADOOP_VERSION}' configuration"
+    echo "Using Hadoop version '${HADOOP_VERSION}' configuration"
     echo
     break
   done
-elif [[ "${HADOOP_VERSION}" != "1" && "${HADOOP_VERSION}" != "2" ]]; then
-  echo "Invalid Apache Hadoop version"
-  echo "Supported Apache Hadoop versions: '1' '2'"
+elif [[ "${HADOOP_VERSION}" != "1" && "${HADOOP_VERSION}" != "2" && "${HADOOP_VERSION}"
!= "HDP2" && "${HADOOP_VERSION}" != "HDP2.2" ]]; then
+  echo "Invalid Hadoop version"
+  echo "Supported Hadoop versions: '1', '2', 'HDP2', 'HDP2.2'"
   exit 1
 fi
 
@@ -300,6 +304,53 @@ if [[ "$HADOOP_VERSION" = "1" ]]; then
       -e 's/<!-- End Hadoop 2 requirements -->/--><!-- End Hadoop 2 requirements
-->/' \
       ${CONF_DIR}/$ACCUMULO_SITE > temp
   mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.0 requirements -->/<!-- HDP 2.0 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.0 requirements -->/--><!-- End HDP 2.0 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.2 requirements -->/<!-- HDP 2.2 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.2 requirements -->/--><!-- End HDP 2.2 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+elif [[ "${HADOOP_VERSION}" == "2" ]]; then
+  sed -e 's/<!-- Hadoop 1 requirements -->/<!-- Hadoop 1 requirements --><!--/'
\
+      -e 's/<!-- End Hadoop 1 requirements -->/--><!-- End Hadoop 1 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.0 requirements -->/<!-- HDP 2.0 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.0 requirements -->/--><!-- End HDP 2.0 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.2 requirements -->/<!-- HDP 2.2 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.2 requirements -->/--><!-- End HDP 2.2 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+elif [[ "${HADOOP_VERSION}" == "HDP2" ]]; then
+  sed -e 's/<!-- Hadoop 1 requirements -->/<!-- Hadoop 1 requirements --><!--/'
\
+      -e 's/<!-- End Hadoop 1 requirements -->/--><!-- End Hadoop 1 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- Hadoop 2 requirements -->/<!-- Hadoop 2 requirements --><!--/'
\
+      -e 's/<!-- End Hadoop 2 requirements -->/--><!-- End Hadoop 2 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.2 requirements -->/<!-- HDP 2.2 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.2 requirements -->/--><!-- End HDP 2.2 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+elif [[ "${HADOOP_VERSION}" == "HDP2.2" ]]; then
+  sed -e 's/<!-- Hadoop 1 requirements -->/<!-- Hadoop 1 requirements --><!--/'
\
+      -e 's/<!-- End Hadoop 1 requirements -->/--><!-- End Hadoop 1 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- Hadoop 2 requirements -->/<!-- Hadoop 2 requirements --><!--/'
\
+      -e 's/<!-- End Hadoop 2 requirements -->/--><!-- End Hadoop 2 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
+  sed -e 's/<!-- HDP 2.0 requirements -->/<!-- HDP 2.0 requirements --><!--/'
\
+      -e 's/<!-- End HDP 2.0 requirements -->/--><!-- End HDP 2.0 requirements
-->/' \
+      ${CONF_DIR}/$ACCUMULO_SITE > temp
+  mv temp  ${CONF_DIR}/$ACCUMULO_SITE
 fi
 
 #Additional setup steps for native configuration.

http://git-wip-us.apache.org/repos/asf/accumulo/blob/7ccae952/assemble/conf/templates/accumulo-site.xml
----------------------------------------------------------------------
diff --git a/assemble/conf/templates/accumulo-site.xml b/assemble/conf/templates/accumulo-site.xml
index a59e4a5..7fe3fe4 100644
--- a/assemble/conf/templates/accumulo-site.xml
+++ b/assemble/conf/templates/accumulo-site.xml
@@ -109,23 +109,28 @@ ${mvnProjBaseDir}
       $HADOOP_PREFIX/share/hadoop/mapreduce/[^.].*.jar,
       $HADOOP_PREFIX/share/hadoop/yarn/[^.].*.jar,
       $HADOOP_PREFIX/share/hadoop/yarn/lib/jersey.*.jar,
+      <!-- End Hadoop 2 requirements -->
+      <!-- HDP 2.0 requirements -->
       /usr/lib/hadoop/[^.].*.jar,
       /usr/lib/hadoop/lib/[^.].*.jar,
       /usr/lib/hadoop-hdfs/[^.].*.jar,
       /usr/lib/hadoop-mapreduce/[^.].*.jar,
       /usr/lib/hadoop-yarn/[^.].*.jar,
       /usr/lib/hadoop-yarn/lib/jersey.*.jar,
+      <!-- End HDP 2.0 requirements -->
+      <!-- HDP 2.2 requirements -->
       /usr/hdp/current/hadoop-client/[^.].*.jar,
       /usr/hdp/current/hadoop-client/lib/(?!slf4j)[^.].*.jar,
       /usr/hdp/current/hadoop-hdfs-client/[^.].*.jar,
       /usr/hdp/current/hadoop-mapreduce-client/[^.].*.jar,
       /usr/hdp/current/hadoop-yarn-client/[^.].*.jar,
       /usr/hdp/current/hadoop-yarn-client/lib/jersey.*.jar,
-      <!-- End Hadoop 2 requirements -->
       /usr/hdp/current/hive-client/lib/hive-accumulo-handler.jar
+      <!-- End HDP 2.2 requirements -->
       <!-- Hadoop 1 requirements -->
       $HADOOP_PREFIX/[^.].*.jar,
       $HADOOP_PREFIX/lib/(?!slf4j)[^.].*.jar,
+      <!-- End Hadoop 1 requirements -->
     </value>
     <description>Classpaths that accumulo checks for updates and class files.</description>
   </property>


Mime
View raw message