accumulo-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From md...@apache.org
Subject [14/18] git commit: Merge branch '1.4.5-SNAPSHOT' into 1.5.1-SNAPSHOT
Date Tue, 07 Jan 2014 00:24:37 GMT
Merge branch '1.4.5-SNAPSHOT' into 1.5.1-SNAPSHOT


Project: http://git-wip-us.apache.org/repos/asf/accumulo/repo
Commit: http://git-wip-us.apache.org/repos/asf/accumulo/commit/a91ee4dd
Tree: http://git-wip-us.apache.org/repos/asf/accumulo/tree/a91ee4dd
Diff: http://git-wip-us.apache.org/repos/asf/accumulo/diff/a91ee4dd

Branch: refs/heads/1.5.1-SNAPSHOT
Commit: a91ee4dde68fd96e2fb3014d2a811b860564979e
Parents: 65aaddd 71f150a
Author: Mike Drob <mdrob@cloudera.com>
Authored: Mon Jan 6 16:14:20 2014 -0800
Committer: Mike Drob <mdrob@cloudera.com>
Committed: Mon Jan 6 16:14:20 2014 -0800

----------------------------------------------------------------------
 README       | 10 +++++-----
 pom.xml      | 45 ++++++++++++++++++++++++++++++++++++---------
 test/pom.xml | 36 +++++++++++++++++++++++++++++-------
 3 files changed, 70 insertions(+), 21 deletions(-)
----------------------------------------------------------------------


http://git-wip-us.apache.org/repos/asf/accumulo/blob/a91ee4dd/README
----------------------------------------------------------------------
diff --cc README
index a100077,f32d606..b0fbcbd
--- a/README
+++ b/README
@@@ -11,21 -11,21 +11,21 @@@ key/value pairs at various points in th
  1. Building
  
  In the normal tarball or RPM release of accumulo, everything is built and
 -ready to go on x86 GNU/Linux for Hadoop 0.20.x and Hadoop 1.x: there is no
 -build step.
 +ready to go on x86 GNU/Linux: there is no build step.
  
 -However, if you only have source code, or you wish to make changes, or you
 -wish to run under a different version of Hadoop, you need to have Maven
 -configured to get Accumulo prerequisites from repositories.  See the pom.xml
 -file for the necessary components.
 +However, if you only have source code, or you wish to make changes, you need to
 +have maven configured to get Accumulo prerequisites from repositories.  See
 +the pom.xml file for the necessary components. Activate the 'docs' profile to build
 +the Accumulo developer and user manual.
  
 -Run "mvn package && mvn assembly:single -N". By default, Accumulo compiles
 -against Hadoop 0.20.203.0.  To compile against a different version
 +Run "mvn package -P assemble" to build a distribution, or run 
 +"mvn package -P assemble,docs" to also build the documentation. By default, 
- Accumulo compiles against Hadoop 1.0.4.  To compile against a different version
- that is compatible with Hadoop 1.0, specify hadoop.version on the command line,
++Accumulo compiles against Hadoop 1.2.1.  To compile against a different version
+ that is compatible with Hadoop 1, specify hadoop.version on the command line,
  e.g. "-Dhadoop.version=0.20.205.0" or "-Dhadoop.version=1.1.0".  To compile 
- against Hadoop 2.0, specify "-Dhadoop.profile=2.0".  By default this uses
- 2.0.4-alpha.  To compile against a different 2.0-compatible version, specify
- the profile and version, e.g. "-Dhadoop.profile=2.0 -Dhadoop.version=0.23.5".
+ against Hadoop 2, specify "-Dhadoop.profile=2".  By default this uses
 -2.2.0.  To compile against a different Hadoop 2-compatible version, specify
++2.2.0.  To compile against a different 2-compatible version, specify
+ the profile and version, e.g. "-Dhadoop.profile=2 -Dhadoop.version=0.23.5".
  
  If you are running on another Unix-like operating system (OSX, etc) then
  you may wish to build the native libraries.  They are not strictly necessary

http://git-wip-us.apache.org/repos/asf/accumulo/blob/a91ee4dd/pom.xml
----------------------------------------------------------------------
diff --cc pom.xml
index 241d116,92d8106..2d5f663
--- a/pom.xml
+++ b/pom.xml
@@@ -20,337 -21,316 +20,337 @@@
    <parent>
      <groupId>org.apache</groupId>
      <artifactId>apache</artifactId>
 -    <version>10</version>
 +    <version>13</version>
    </parent>
 -
 -
    <groupId>org.apache.accumulo</groupId>
 -  <artifactId>accumulo</artifactId>
 +  <artifactId>accumulo-project</artifactId>
 +  <version>1.5.1-SNAPSHOT</version>
    <packaging>pom</packaging>
 -  <version>1.4.5-SNAPSHOT</version>
 -  <name>accumulo</name>
 -
 +  <name>Apache Accumulo Project</name>
 +  <description>Apache Accumulo is a sorted, distributed key/value store based on Google's BigTable design. It is built on top of Apache Hadoop, Zookeeper, and Thrift. It features a few novel improvements on the BigTable design in the form of cell-level access labels and a server-side programming mechanism that can modify key/value pairs at various points in the data management process.</description>
 +  <!-- this URL is where the site derived via the maven-site-plugin ends up, not the generic site -->
 +  <url>http://accumulo.apache.org/maven-site/</url>
 +  <organization>
 +    <name>Apache Accumulo Project</name>
 +    <url>http://accumulo.apache.org/</url>
 +  </organization>
 +  <licenses>
 +    <license>
 +      <name>Apache License, Version 2.0</name>
 +      <url>http://www.apache.org/licenses/LICENSE-2.0</url>
 +    </license>
 +  </licenses>
 +  <mailingLists>
 +    <mailingList>
 +      <name>User</name>
 +      <subscribe>user-subscribe@accumulo.apache.org</subscribe>
 +      <unsubscribe>user-unsubscribe@accumulo.apache.org</unsubscribe>
 +      <post>user@accumulo.apache.org</post>
 +      <archive>http://mail-archives.apache.org/mod_mbox/accumulo-user</archive>
 +    </mailingList>
 +    <mailingList>
 +      <name>Dev</name>
 +      <subscribe>dev-subscribe@accumulo.apache.org</subscribe>
 +      <unsubscribe>dev-unsubscribe@accumulo.apache.org</unsubscribe>
 +      <post>dev@accumulo.apache.org</post>
 +      <archive>http://mail-archives.apache.org/mod_mbox/accumulo-dev</archive>
 +    </mailingList>
 +    <mailingList>
 +      <name>Commits</name>
 +      <subscribe>commits-subscribe@accumulo.apache.org</subscribe>
 +      <unsubscribe>commits-unsubscribe@accumulo.apache.org</unsubscribe>
 +      <archive>http://mail-archives.apache.org/mod_mbox/accumulo-commits</archive>
 +    </mailingList>
 +    <mailingList>
 +      <name>Notifications</name>
 +      <subscribe>notifications-subscribe@accumulo.apache.org</subscribe>
 +      <unsubscribe>notifications-unsubscribe@accumulo.apache.org</unsubscribe>
 +      <archive>http://mail-archives.apache.org/mod_mbox/accumulo-notifications</archive>
 +    </mailingList>
 +  </mailingLists>
 +  <prerequisites>
 +    <maven>${maven.min-version}</maven>
 +  </prerequisites>
    <modules>
 -    <module>src/trace</module>
 -    <module>src/core</module>
 -    <module>src/server</module>
 -    <module>src/start</module>
 -    <module>src/examples</module>
 -    <module>src/proxy</module>
 -    <module>src/minicluster</module>
 +    <module>trace</module>
 +    <module>core</module>
 +    <module>fate</module>
 +    <module>server</module>
 +    <module>start</module>
 +    <module>examples</module>
 +    <module>assemble</module>
 +    <module>proxy</module>
 +    <module>test</module>
 +    <module>minicluster</module>
    </modules>
 -
 -  <build>
 -    <resources>
 -      <resource>
 -        <directory>${basedir}/src/main/resources</directory>
 -      </resource>
 -    </resources>
 -    <defaultGoal>package</defaultGoal>
 -    <plugins>
 -      <plugin>
 -        <groupId>org.apache.maven.plugins</groupId>
 -        <artifactId>maven-enforcer-plugin</artifactId>
 -        <executions>
 -          <execution>
 -            <id>enforce-mvn</id>
 -            <goals>
 -              <goal>enforce</goal>
 -            </goals>
 -            <configuration>
 -              <rules>
 -                <requireMavenVersion>
 -                  <version>[2.0.9,)</version>
 -                </requireMavenVersion>
 -                <requireProperty>
 -                  <property>hadoop.profile</property>
 -                  <regex>(1|2)</regex>
 -                  <regexMessage>You should specify the Hadoop profile by major Hadoop generation, i.e. 1 or 2, not by a version number.
 -    Use hadoop.version to use a particular Hadoop version within that generation. See README for more details.</regexMessage>
 -                </requireProperty>
 -              </rules>
 -            </configuration>
 -          </execution>
 -        </executions>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-clean-plugin</artifactId>
 -        <configuration>
 -          <filesets>
 -            <fileset>
 -              <directory>lib</directory>
 -              <includes>
 -                <include>*.jar</include>
 -              </includes>
 -            </fileset>
 -            <fileset>
 -              <directory>docs/apidocs</directory>
 -            </fileset>
 -            <fileset>
 -              <directory>test</directory>
 -              <includes>
 -                <include>**/*.so</include>
 -              </includes>
 -            </fileset>
 -            <fileset>
 -              <directory>./</directory>
 -              <includes>
 -                <include>**/*.pyc</include>
 -              </includes>
 -            </fileset>
 -          </filesets>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <groupId>com.github.koraktor</groupId>
 -        <artifactId>mavanagaiata</artifactId>
 -        <executions>
 -          <execution>
 -            <id>git-commit</id>
 -            <phase>validate</phase>
 -            <goals>
 -              <goal>commit</goal>
 -            </goals>
 -          </execution>
 -        </executions>
 -      </plugin>
 -      <plugin>
 -        <groupId>org.apache.maven.plugins</groupId>
 -        <artifactId>maven-dependency-plugin</artifactId>
 -        <executions>
 -          <execution>
 -            <id>copy-dependencies</id>
 -            <phase>process-resources</phase>
 -            <goals>
 -              <goal>copy-dependencies</goal>
 -            </goals>
 -            <configuration>
 -              <outputDirectory>../../lib</outputDirectory>
 -              <!-- just grab the non-provided runtime dependencies -->
 -              <includeArtifactIds>commons-collections,commons-configuration,commons-io,commons-lang,jline,log4j,libthrift,commons-jci-core,commons-jci-fam,commons-logging,commons-logging-api,guava</includeArtifactIds>
 -              <excludeTransitive>true</excludeTransitive>
 -            </configuration>
 -          </execution>
 -        </executions>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-jar-plugin</artifactId>
 -        <configuration>
 -          <outputDirectory>../../lib</outputDirectory>
 -          <archive>
 -            <manifest>
 -              <addDefaultImplementationEntries>true</addDefaultImplementationEntries>
 -              <addDefaultSpecificationEntries>true</addDefaultSpecificationEntries>
 -            </manifest>
 -            <manifestEntries>
 -              <Implementation-Build>${mvngit.commit.id}</Implementation-Build>
 -            </manifestEntries>
 -          </archive>
 -          <includes>
 -            <include>cloudtrace/**</include>
 -            <include>org/apache/accumulo**/**</include>
 -            <include>web/**</include>
 -            <include>randomwalk/**</include>
 -            <include>*.*</include>
 -            <include>**/META-INF/*</include>
 -          </includes>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-resources-plugin</artifactId>
 -        <configuration>
 -          <encoding>UTF-8</encoding>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-assembly-plugin</artifactId>
 -        <configuration>
 -          <descriptors>
 -            <descriptor>src/assemble/dist.xml</descriptor>
 -          </descriptors>
 -          <tarLongFileMode>gnu</tarLongFileMode>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-compiler-plugin</artifactId>
 -        <configuration>
 -          <source>1.6</source>
 -          <target>1.6</target>
 -          <optimize>true</optimize>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-javadoc-plugin</artifactId>
 -        <configuration>
 -          <encoding>UTF-8</encoding>
 -          <quiet>true</quiet>
 -          <jarOutputDirectory>lib</jarOutputDirectory>
 -          <reportOutputDirectory>docs</reportOutputDirectory>
 -          <javadocVersion>1.6</javadocVersion>
 -          <additionalJOption>-J-Xmx512m</additionalJOption>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-source-plugin</artifactId>
 -        <configuration>
 -          <outputDirectory>../../lib</outputDirectory>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <artifactId>maven-surefire-plugin</artifactId>
 -        <configuration>
 -          <environmentVariables>
 -            <ACCUMULO_HOME>../..</ACCUMULO_HOME>
 -          </environmentVariables>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <groupId>org.codehaus.mojo</groupId>
 -        <artifactId>rpm-maven-plugin</artifactId>
 -        <version>2.1-alpha-3</version>
 -        <inherited>false</inherited>
 -        <configuration>
 -          <name>accumulo</name>
 -          <projversion>${project.version}</projversion>
 -          <summary>Apache Accumulo BigTable clone</summary>
 -          <description>
 -            Apache Accumulo is a large distributed structured store based on
 -            Google's BigTable design.
 -          </description>
 -          <copyright>2011 The Apache Software Foundation.</copyright>
 -          <url>http://accumulo.apache.org</url>
 -          <needarch>x86_64</needarch>
 -          <group>Utilities</group>
 -          <requires>
 -            <require>jdk</require>
 -            <require>hadoop</require>
 -            <require>zookeeper</require>
 -          </requires>
 -          <prefix>/opt/accumulo</prefix>
 -          <defaultDirmode>755</defaultDirmode>
 -          <defaultFilemode>644</defaultFilemode>
 -          <defaultUsername>root</defaultUsername>
 -          <defaultGroupname>root</defaultGroupname>
 -          <mappings>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}</directory>
 -              <sources>
 -                <source>
 -                  <location>README</location>
 -                </source>
 -              </sources>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/docs</directory>
 -              <sources>
 -                <source>
 -                  <location>docs</location>
 -                </source>
 -              </sources>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/test</directory>
 -              <sources>
 -                <source>
 -                  <location>test</location>
 -                  <excludes>
 -                    <exclude>**/walkers.txt</exclude>
 -                    <exclude>**/ingesters.txt</exclude>
 -                    <exclude>**/continuous-env.sh</exclude>
 -                    <exclude>**/*.pyc</exclude>
 -                  </excludes>
 -                </source>
 -              </sources>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/bin</directory>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/bin</directory>
 -              <directoryIncluded>false</directoryIncluded>
 -              <filemode>755</filemode>
 -              <username>root</username>
 -              <groupname>root</groupname>
 -              <sources>
 -                <source>
 -                  <location>bin</location>
 -                </source>
 -              </sources>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/conf</directory>
 -              <sources>
 -                <source>
 -                  <location>conf</location>
 -                  <excludes>
 -                    <exclude>**/accumulo-site.xml</exclude>
 -                    <exclude>**/accumulo-env.sh</exclude>
 -                    <exclude>**/accumulo-metrics.xml</exclude>
 -                    <exclude>**/test-*</exclude>
 -                    <exclude>**/slaves</exclude>
 -                    <exclude>**/masters</exclude>
 -                    <exclude>**/tracers</exclude>
 -                    <exclude>**/gc</exclude>
 -                    <exclude>**/monitor</exclude>
 -                  </excludes>
 -                </source>
 -              </sources>
 -            </mapping>
 -            <mapping>
 -              <directory>/opt/accumulo/accumulo-${project.version}/lib</directory>
 -              <dependency />
 -              <sources>
 -                <source>
 -                  <location>lib</location>
 -                </source>
 -              </sources>
 -            </mapping>
 -          </mappings>
 -        </configuration>
 -      </plugin>
 -      <plugin>
 -        <groupId>org.codehaus.mojo</groupId>
 -        <artifactId>exec-maven-plugin</artifactId>
 -        <inherited>false</inherited>
 +  <scm>
 +    <connection>scm:git:git://git.apache.org/accumulo.git</connection>
 +    <developerConnection>scm:git:https://git-wip-us.apache.org/repos/asf/accumulo.git</developerConnection>
 +    <url>https://git-wip-us.apache.org/repos/asf?p=accumulo.git</url>
 +  </scm>
 +  <issueManagement>
 +    <system>JIRA</system>
 +    <url>https://issues.apache.org/jira/browse/ACCUMULO</url>
 +  </issueManagement>
 +  <ciManagement>
 +    <system>Apache Jenkins</system>
 +    <url>https://builds.apache.org/view/A-D/view/Accumulo/</url>
 +  </ciManagement>
 +  <distributionManagement>
 +    <site>
 +      <id>accumulo.mvn.website</id>
 +      <name>Accumulo Maven Site</name>
 +      <!-- this is not likely to be what we really want, but it's good enough for a test -->
 +      <url>scm:svn:https://svn.apache.org/repos/asf/accumulo/site/trunk/maven-site</url>
 +    </site>
 +  </distributionManagement>
 +  <properties>
 +    <!-- used for filtering the java source with the current version -->
 +    <accumulo.release.version>${project.version}</accumulo.release.version>
-     <!-- overwritten in profiles hadoop-1.0 or hadoop-2.0 -->
++    <!-- overwritten in profiles hadoop-1 or hadoop-2 -->
 +    <hadoop.version>1.2.1</hadoop.version>
 +    <httpclient.version>3.0.1</httpclient.version>
 +    <!-- the maven-release-plugin makes this recommendation, due to plugin bugs -->
 +    <maven.min-version>3.0.4</maven.min-version>
 +    <powermock.version>1.5</powermock.version>
 +    <project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>
 +    <project.reporting.outputEncoding>UTF-8</project.reporting.outputEncoding>
 +    <sealJars>false</sealJars>
-     <!-- overwritten in profiles hadoop-1.0 or hadoop-2.0 -->
++    <!-- overwritten in profiles hadoop-1 or hadoop-2 -->
 +    <slf4j.version>1.4.3</slf4j.version>
 +    <!-- ZooKeeper 3.4.x works also, but we're not using new features yet; this ensures 3.3.x compatibility. -->
 +    <zookeeper.version>3.3.6</zookeeper.version>
 +  </properties>
 +  <dependencyManagement>
 +    <dependencies>
 +      <dependency>
 +        <groupId>com.beust</groupId>
 +        <artifactId>jcommander</artifactId>
 +        <version>1.30</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>com.google.code.gson</groupId>
 +        <artifactId>gson</artifactId>
 +        <version>2.2.2</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>com.google.guava</groupId>
 +        <artifactId>guava</artifactId>
 +        <version>14.0.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-cli</groupId>
 +        <artifactId>commons-cli</artifactId>
          <version>1.2</version>
 -        <configuration>
 -          <executable>bash</executable>
 -          <arguments>
 -            <argument>docs/src/user_manual/build.sh</argument>
 -          </arguments>
 -        </configuration>
 -        <executions>
 -          <execution>
 -            <id>user-manual</id>
 -            <phase>prepare-package</phase>
 -            <goals>
 -              <goal>exec</goal>
 -            </goals>
 -          </execution>
 -        </executions>
 -      </plugin>
 -    </plugins>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-codec</groupId>
 +        <artifactId>commons-codec</artifactId>
 +        <version>1.4</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-collections</groupId>
 +        <artifactId>commons-collections</artifactId>
 +        <version>3.2.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-configuration</groupId>
 +        <artifactId>commons-configuration</artifactId>
 +        <version>1.6</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-httpclient</groupId>
 +        <artifactId>commons-httpclient</artifactId>
 +        <version>${httpclient.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-io</groupId>
 +        <artifactId>commons-io</artifactId>
 +        <version>2.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-lang</groupId>
 +        <artifactId>commons-lang</artifactId>
 +        <version>2.4</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-logging</groupId>
 +        <artifactId>commons-logging</artifactId>
 +        <version>1.1.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>commons-logging</groupId>
 +        <artifactId>commons-logging-api</artifactId>
 +        <version>1.0.4</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>javax.servlet</groupId>
 +        <artifactId>servlet-api</artifactId>
 +        <version>2.5</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>javax.ws.rs</groupId>
 +        <artifactId>jsr311-api</artifactId>
 +        <version>1.1.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>jline</groupId>
 +        <artifactId>jline</artifactId>
 +        <version>1.0</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>junit</groupId>
 +        <artifactId>junit</artifactId>
 +        <version>4.11</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>log4j</groupId>
 +        <artifactId>log4j</artifactId>
 +        <version>1.2.16</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-core</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-examples-simple</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-fate</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-minicluster</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-proxy</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-server</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-start</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-test</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.accumulo</groupId>
 +        <artifactId>accumulo-trace</artifactId>
 +        <version>${project.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.commons</groupId>
 +        <artifactId>commons-jci-core</artifactId>
 +        <version>1.0</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.commons</groupId>
 +        <artifactId>commons-jci-fam</artifactId>
 +        <version>1.0</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.commons</groupId>
 +        <artifactId>commons-math</artifactId>
 +        <version>2.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.commons</groupId>
 +        <artifactId>commons-vfs2</artifactId>
 +        <version>2.0</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.hadoop</groupId>
 +        <artifactId>hadoop-client</artifactId>
 +        <version>${hadoop.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.hadoop</groupId>
 +        <artifactId>hadoop-distcp</artifactId>
 +        <version>${hadoop.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.hadoop</groupId>
 +        <artifactId>hadoop-minicluster</artifactId>
 +        <version>${hadoop.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.hadoop</groupId>
 +        <artifactId>hadoop-tools</artifactId>
 +        <version>${hadoop.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.thrift</groupId>
 +        <artifactId>libthrift</artifactId>
 +        <version>0.9.0</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.apache.zookeeper</groupId>
 +        <artifactId>zookeeper</artifactId>
 +        <version>${zookeeper.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.easymock</groupId>
 +        <artifactId>easymock</artifactId>
 +        <version>3.1</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.mortbay.jetty</groupId>
 +        <artifactId>jetty</artifactId>
 +        <version>6.1.26</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.powermock</groupId>
 +        <artifactId>powermock-api-easymock</artifactId>
 +        <version>${powermock.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.powermock</groupId>
 +        <artifactId>powermock-core</artifactId>
 +        <version>${powermock.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.powermock</groupId>
 +        <artifactId>powermock-module-junit4</artifactId>
 +        <version>${powermock.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.powermock</groupId>
 +        <artifactId>powermock-reflect</artifactId>
 +        <version>${powermock.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.slf4j</groupId>
 +        <artifactId>slf4j-api</artifactId>
 +        <version>${slf4j.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.slf4j</groupId>
 +        <artifactId>slf4j-log4j12</artifactId>
 +        <version>${slf4j.version}</version>
 +      </dependency>
 +      <dependency>
 +        <groupId>org.slf4j</groupId>
 +        <artifactId>slf4j-nop</artifactId>
 +        <version>${slf4j.version}</version>
 +      </dependency>
 +    </dependencies>
 +  </dependencyManagement>
 +  <build>
      <pluginManagement>
        <plugins>
          <plugin>
@@@ -625,119 -419,18 +625,125 @@@
              </lifecycleMappingMetadata>
            </configuration>
          </plugin>
 -        <plugin>
 -          <groupId>com.github.koraktor</groupId>
 -          <artifactId>mavanagaiata</artifactId>
 -          <version>0.6.1</version>
 -          <configuration>
 -            <skipNoGit>true</skipNoGit>
 -          </configuration>
 -        </plugin>
        </plugins>
      </pluginManagement>
 +    <plugins>
 +      <plugin>
 +        <!-- verify only; 'mvn clean -P sortpom' sorts -->
 +        <groupId>com.google.code.sortpom</groupId>
 +        <artifactId>maven-sortpom-plugin</artifactId>
 +        <executions>
 +          <execution>
 +            <id>verify-sorted-pom</id>
 +            <goals>
 +              <goal>verify</goal>
 +            </goals>
 +            <phase>validate</phase>
 +          </execution>
 +        </executions>
 +      </plugin>
 +      <plugin>
 +        <groupId>org.apache.maven.plugins</groupId>
 +        <artifactId>maven-dependency-plugin</artifactId>
 +        <executions>
 +          <execution>
 +            <id>copy-dependencies</id>
 +            <goals>
 +              <goal>copy-dependencies</goal>
 +            </goals>
 +            <phase>prepare-package</phase>
 +            <configuration>
 +              <outputDirectory>../lib</outputDirectory>
 +              <!-- just grab the non-provided runtime dependencies -->
 +              <stripVersion>true</stripVersion>
 +              <includeScope>runtime</includeScope>
 +              <excludeTransitive>true</excludeTransitive>
 +              <excludeClassifiers>sources,test-sources</excludeClassifiers>
 +            </configuration>
 +          </execution>
 +        </executions>
 +      </plugin>
 +      <plugin>
 +        <groupId>org.apache.maven.plugins</groupId>
 +        <artifactId>maven-enforcer-plugin</artifactId>
 +        <executions>
 +          <execution>
 +            <id>enforce-mvn</id>
 +            <goals>
 +              <goal>enforce</goal>
 +            </goals>
 +            <configuration>
 +              <rules>
 +                <requireMavenVersion>
 +                  <version>[${maven.min-version},)</version>
 +                </requireMavenVersion>
++                <requireProperty>
++                  <property>hadoop.profile</property>
++                  <regex>(1|2)</regex>
++                  <regexMessage>You should specify the Hadoop profile by major Hadoop generation, i.e. 1 or 2, not by a version number.
++    Use hadoop.version to use a particular Hadoop version within that generation. See README for more details.</regexMessage>
++                </requireProperty>
 +              </rules>
 +            </configuration>
 +          </execution>
 +        </executions>
 +      </plugin>
 +      <plugin>
 +        <groupId>com.github.koraktor</groupId>
 +        <artifactId>mavanagaiata</artifactId>
 +        <executions>
 +          <execution>
 +            <id>git-commit</id>
 +            <goals>
 +              <goal>commit</goal>
 +            </goals>
 +            <phase>validate</phase>
 +          </execution>
 +        </executions>
 +      </plugin>
 +      <plugin>
 +        <groupId>org.apache.maven.plugins</groupId>
 +        <artifactId>maven-failsafe-plugin</artifactId>
 +        <executions>
 +          <execution>
 +            <id>run-integration-tests</id>
 +            <goals>
 +              <goal>integration-test</goal>
 +            </goals>
 +            <phase>integration-test</phase>
 +          </execution>
 +          <execution>
 +            <id>verify-integration-tests</id>
 +            <goals>
 +              <goal>verify</goal>
 +            </goals>
 +            <phase>verify</phase>
 +          </execution>
 +        </executions>
 +      </plugin>
 +      <plugin>
 +        <groupId>org.apache.maven.plugins</groupId>
 +        <artifactId>maven-scm-publish-plugin</artifactId>
 +        <executions>
 +          <execution>
 +            <id>scm-publish</id>
 +            <goals>
 +              <goal>publish-scm</goal>
 +            </goals>
 +            <phase>site-deploy</phase>
 +          </execution>
 +        </executions>
 +      </plugin>
 +    </plugins>
 +    <extensions>
 +      <extension>
 +        <!-- enable ssh deployment of site with maven 3 -->
 +        <groupId>org.apache.maven.wagon</groupId>
 +        <artifactId>wagon-ssh</artifactId>
 +        <version>2.4</version>
 +      </extension>
 +    </extensions>
    </build>
 -
    <reporting>
      <plugins>
        <plugin>
@@@ -939,31 -711,70 +945,52 @@@
              </configuration>
            </plugin>
          </plugins>
 -      </build>
 +      </reporting>
      </profile>
+     <!-- profile for our default Hadoop build
+          unfortunately, has to duplicate one of our
+          specified profiles. see MNG-3328 -->
      <profile>
-       <!-- profile for building against Hadoop 1.0.x
-       Activate by not specifying hadoop.profile -->
-       <id>hadoop-1.0</id>
+       <id>hadoop-default</id>
        <activation>
          <property>
            <name>!hadoop.profile</name>
          </property>
        </activation>
        <properties>
+         <!-- Denotes intention and allows the enforcer plugin to pass when
+              the user is relying on default behavior; won't work to activate profile -->
+         <hadoop.profile>1</hadoop.profile>
 -        <hadoop.version>0.20.203.0</hadoop.version>
 +        <hadoop.version>1.2.1</hadoop.version>
 +        <httpclient.version>3.0.1</httpclient.version>
          <slf4j.version>1.4.3</slf4j.version>
        </properties>
 -      <dependencyManagement>
 -        <dependencies>
 -          <dependency>
 -            <groupId>org.apache.hadoop</groupId>
 -            <artifactId>hadoop-core</artifactId>
 -            <version>${hadoop.version}</version>
 -            <scope>provided</scope>
 -          </dependency>
 -        </dependencies>
 -      </dependencyManagement>
      </profile>
+     <!-- profile for building against Hadoop 1.x
+      XXX Since this is the default, make sure to sync hadoop-default when changing.
+     Activate using: mvn -Dhadoop.profile=1 -->
      <profile>
-       <!-- profile for building against Hadoop 2.0.x
-       Activate using: mvn -Dhadoop.profile=2.0 -->
-       <id>hadoop-2.0</id>
+       <id>hadoop-1</id>
        <activation>
          <property>
            <name>hadoop.profile</name>
-           <value>2.0</value>
+           <value>1</value>
+         </property>
+       </activation>
+       <properties>
 -        <hadoop.version>0.20.203.0</hadoop.version>
++        <hadoop.version>1.2.1</hadoop.version>
++        <httpclient.version>3.0.1</httpclient.version>
+         <slf4j.version>1.4.3</slf4j.version>
+       </properties>
 -      <dependencyManagement>
 -        <dependencies>
 -          <dependency>
 -            <groupId>org.apache.hadoop</groupId>
 -            <artifactId>hadoop-core</artifactId>
 -            <version>${hadoop.version}</version>
 -            <scope>provided</scope>
 -          </dependency>
 -        </dependencies>
 -      </dependencyManagement>
+     </profile>
+     <!-- profile for building against Hadoop 2.x
+     Activate using: mvn -Dhadoop.profile=2 -->
+     <profile>
+       <id>hadoop-2</id>
+       <activation>
+         <property>
+           <name>hadoop.profile</name>
+           <value>2</value>
          </property>
        </activation>
        <properties>

http://git-wip-us.apache.org/repos/asf/accumulo/blob/a91ee4dd/test/pom.xml
----------------------------------------------------------------------
diff --cc test/pom.xml
index 1d3dce4,0000000..9579581
mode 100644,000000..100644
--- a/test/pom.xml
+++ b/test/pom.xml
@@@ -1,167 -1,0 +1,189 @@@
 +<?xml version="1.0" encoding="UTF-8"?>
 +<!--
 +  Licensed to the Apache Software Foundation (ASF) under one or more
 +  contributor license agreements.  See the NOTICE file distributed with
 +  this work for additional information regarding copyright ownership.
 +  The ASF licenses this file to You under the Apache License, Version 2.0
 +  (the "License"); you may not use this file except in compliance with
 +  the License.  You may obtain a copy of the License at
 +
 +      http://www.apache.org/licenses/LICENSE-2.0
 +
 +  Unless required by applicable law or agreed to in writing, software
 +  distributed under the License is distributed on an "AS IS" BASIS,
 +  WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
 +  See the License for the specific language governing permissions and
 +  limitations under the License.
 +-->
 +<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
 +  <modelVersion>4.0.0</modelVersion>
 +  <parent>
 +    <groupId>org.apache.accumulo</groupId>
 +    <artifactId>accumulo-project</artifactId>
 +    <version>1.5.1-SNAPSHOT</version>
 +  </parent>
 +  <artifactId>accumulo-test</artifactId>
 +  <name>Testing</name>
 +  <dependencies>
 +    <dependency>
 +      <groupId>com.beust</groupId>
 +      <artifactId>jcommander</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>jline</groupId>
 +      <artifactId>jline</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-core</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-fate</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-minicluster</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-server</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-start</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.accumulo</groupId>
 +      <artifactId>accumulo-trace</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.thrift</groupId>
 +      <artifactId>libthrift</artifactId>
 +    </dependency>
 +    <dependency>
 +      <groupId>commons-cli</groupId>
 +      <artifactId>commons-cli</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>commons-codec</groupId>
 +      <artifactId>commons-codec</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>commons-io</groupId>
 +      <artifactId>commons-io</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>log4j</groupId>
 +      <artifactId>log4j</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.commons</groupId>
 +      <artifactId>commons-math</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.hadoop</groupId>
 +      <artifactId>hadoop-client</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.apache.zookeeper</groupId>
 +      <artifactId>zookeeper</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.slf4j</groupId>
 +      <artifactId>slf4j-api</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>org.slf4j</groupId>
 +      <artifactId>slf4j-log4j12</artifactId>
 +      <scope>provided</scope>
 +    </dependency>
 +    <dependency>
 +      <groupId>junit</groupId>
 +      <artifactId>junit</artifactId>
 +      <scope>test</scope>
 +    </dependency>
 +  </dependencies>
 +  <build>
 +    <pluginManagement>
 +      <plugins>
 +        <plugin>
 +          <groupId>org.apache.rat</groupId>
 +          <artifactId>apache-rat-plugin</artifactId>
 +          <configuration>
 +            <excludes>
 +              <exclude>system/bench/lib/*splits</exclude>
 +            </excludes>
 +          </configuration>
 +        </plugin>
 +      </plugins>
 +    </pluginManagement>
 +  </build>
 +  <profiles>
 +    <profile>
-       <!-- profile for building against Hadoop 1.0.x
-       Activate by not specifying hadoop.profile -->
-       <id>hadoop-1.0</id>
++      <id>hadoop-default</id>
 +      <activation>
 +        <property>
 +          <name>!hadoop.profile</name>
 +        </property>
 +      </activation>
++      <properties>
++        <!-- Denotes intention and allows the enforcer plugin to pass when
++             the user is relying on default behavior; won't work to activate profile -->
++        <hadoop.profile>1</hadoop.profile>
++      </properties>
 +      <dependencies>
 +        <dependency>
 +          <groupId>org.apache.hadoop</groupId>
 +          <artifactId>hadoop-tools</artifactId>
 +          <scope>test</scope>
 +        </dependency>
 +      </dependencies>
 +    </profile>
++    <!-- profile for building against Hadoop 1.x
++     XXX Since this is the default, make sure to sync hadoop-default when changing.
++    Activate using: mvn -Dhadoop.profile=1 -->
 +    <profile>
-       <!-- profile for building against Hadoop 2.0.x
-       Activate using: mvn -Dhadoop.profile=2.0 -->
-       <id>hadoop-2.0</id>
++      <id>hadoop-1</id>
 +      <activation>
 +        <property>
 +          <name>hadoop.profile</name>
-           <value>2.0</value>
++          <value>1</value>
++        </property>
++      </activation>
++      <dependencies>
++        <dependency>
++          <groupId>org.apache.hadoop</groupId>
++          <artifactId>hadoop-tools</artifactId>
++          <scope>test</scope>
++        </dependency>
++      </dependencies>
++    </profile>
++    <!-- profile for building against Hadoop 2.x
++    Activate using: mvn -Dhadoop.profile=2 -->
++    <profile>
++      <id>hadoop-2</id>
++      <activation>
++        <property>
++          <name>hadoop.profile</name>
++          <value>2</value>
 +        </property>
 +      </activation>
 +      <dependencies>
 +        <dependency>
 +          <groupId>org.apache.hadoop</groupId>
 +          <artifactId>hadoop-distcp</artifactId>
 +          <scope>test</scope>
 +        </dependency>
 +      </dependencies>
 +    </profile>
 +  </profiles>
 +</project>


Mime
View raw message