abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Aki Yoshida <elak...@gmail.com>
Subject Re: Does abdera-parser/1.1.3 need to import org.apache.james.mime4j?
Date Tue, 19 Aug 2014 09:23:29 GMT
I was mistaken for what I said.

There was a dependency to james over axiom-api in my standalone version.
So please ignore my message.
regards, aki

2014-08-19 0:55 GMT+02:00 Aki Yoshida <elakito@gmail.com>:
> I am new to abdera and have this basic dependency question.
>
> I have a standalone program that happens to have dependency to
> abdera-core and abdera-parser.
>
> When I was trying to turn this program into its OSGi version, I
> noticed abdera-parser is importing
> org.apache.james.mime4j and org.apache.james.mime4j.stream.
>
> As my standalone program is not using james, I am wondering if
> abdera-parser could import james with resolution:=optional so that
> those use-cases not using james can run without james.
>
> I would appreciate your feedback.
>
> Thanks.
>
> Regards, Aki

Mime
View raw message