abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Goetzmann Bertrand" <Bertrand.Goetzm...@lasersymag.com>
Subject RE: A minimal Atom server
Date Fri, 03 Oct 2008 13:21:44 GMT
Thank you David,

I used the trunk version, and build Abdera with Maven.

Now I get the correct service document!

But with my Groovy client I get the same error when trying to post an entry (status 400, Bad
I also tried the same thing with Poster, the FireFox's plugin, and get an exception on the
server side and the response indicates an internal error.

What can I try now?
I don't succeed to have a finer grained log4j traces.


-----Message d'origine-----
De : David Calavera [mailto:david.calavera@gmail.com] 
Envoyé : vendredi 3 octobre 2008 12:34
À : abdera-user@incubator.apache.org
Objet : Re: A minimal Atom server

Hi Bertrand,

I think you should use the trunk version from the repository. I'd say we've
solved a bunch of bugs and perhaps you won't these problems.


On Fri, Oct 3, 2008 at 9:43 AM, Goetzmann Bertrand <
Bertrand.Goetzmann@lasersymag.com> wrote:

> Hello,
> I just discover Abdera and I'm very impressed! Thank you to all
> committers to this project.
> So I downloaded the 0.4 version and tried to launch a minimal atom pub
> server, using source code found in the employee folder: it contains
> AppServer.java, Employee.java, and EmployeeCollectionAdapter.java.
> AppServer has the main method and starts a Jetty web server that listens
> on the 9002 port.
> Using NetBenas 6.1 and these three sources I can start the server.
> With a browser I can navigate to the URL http://localhost:9002/employee
> that returns an empty list but a correct response (a Atom document).
> But when I navigate to the URL http://localhost:9002/ in order to get
> the service document I get an empty document (0 byte)!
> I try also to add a new employee using a post command with the following
> code in Groovy language:
> def abdera = new Abdera()
> def factory = abdera.factory
> def client = new AbderaClient(abdera)
> def entry = factory.newEntry()
> entry.addAuthor('Bertrand')
> entry.setContent('<p>...</p>')
> entry.setSummary('...')
> entry.setTitle('...')
> entry.setUpdated(new Date())
> def response = client.post("http://localhost:9002/employee", entry)
> println "POST : $response.type"
> println response.inputStream.text
> But the response type is CLIENT_ERROR and the response text is empty; on
> the server side I don't have any trace. When debugging the
> EmployeeCollectionAdapter.postEntry is not called.
> With the client, if I call the put method,
> EmployeeCollectionAdapter.putEntry is well called.
> So, why I can't get the service document, and what is wrong with my
> client code?
> Thank you for your help.
> Bertrand
> http://www.odelia-technologies.com

David Calavera

View raw message