abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dan Diephouse <dan.diepho...@mulesource.com>
Subject Re: Error configuring eclipse project to use abdera 0.4.0
Date Wed, 02 Apr 2008 17:30:11 GMT
Hi Gavin,
How did you end up with the 1.0.2.rc4 version of the activation jar? We 
distribute geronimo-activation_1.0.2_spec-1.1.jar I thought.

Also I just checked and MimeType is included in the activation-1.1 jar 
as well - so I think you have classpath problems which are local.

Dan

Gavin Bong wrote:
> Hi,
>
> I want to try out abdera 0.4.0; so I've created sample java project
> with the following referenced libraries:-
>
> abdera-core
> commons-codec
> commons-httpclient
> commons-logging
> mina-core
> abdera-i18n
> geronimo-spec-activation 1.0.2.rc4
>
> I'm getting the following errors in the Problems tab in eclipse 3.3.1.1:
>
> error while loading Document, class file
> '/home/gavin/.m2/repository/org/apache/abdera/abdera-core/0.4.0-incubating/abdera-core-0.4.0-incubating.jar(org/apache/abdera/model/Document.class)'
> is broken (class javax.activation.MimeType not found.)
>
> error while loading Document, class file
> '/home/gavin/.m2/repository/org/apache/abdera/abdera-core/0.4.0-incubating/abdera-core-0.4.0-incubating.jar(org/apache/abdera/model/Document.class)'
> is broken (class org.apache.abdera.i18n.iri.IRI not found.)
>
> Can you give me some hints to the problem ?
>
> I've tried adding javax.activation 1.1 and the geronimo spec activation jar
> and both are giving the same problem.
>
> Regards,
>
> Gavin
>
>
>   


-- 
Dan Diephouse
MuleSource
http://mulesource.com | http://netzooid.com 


Mime
View raw message