abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Woody Anderson" <wo...@xoopit.com>
Subject google auth problems (new)
Date Sun, 16 Dec 2007 01:28:57 GMT
hello, i'm using abdera 3.0 and i'm having new (as to say, i did not
previously have this issue) auth issues with posting to blogger.

so, i pretty much have this code prior to post():

        // google's username password scheme
        //
        GoogleLoginAuthScheme.register( getClient(), true );
        GoogleLoginAuthCredentials creds =  new
GoogleLoginAuthCredentials( getUsername(),

     getPassword(),

     "blogger" );
        try {
            getClient().addCredentials( "http://www.blogger.com",
null, "GoogleLogin", creds );
        } catch( URISyntaxException e ) {
            throw new ProtocolException( "bad uri", e );
        }


and i'm watching my packets in wireshark and i see my post goto:

/feeds/xxxxxxxxxxxxxx/posts/default

with header

Authorization: GoogleLogin
auth=DQAAAGwAAABgNw8u_vjXkoKeS1iiD7d-LE9NG7GesHh_zHEHYC2mkf8Xi0yF0-HhmxrVSu1m2tk9cjodf4JpPeuFKLYvJMUREbvaHLJv_b_RGuR_WCbfdNgE3jQPgVfQshCB7wFQVg65N5ll2J5HfCpT5SryNpXE

but i get a 401 back
---------------------------------------------------------------------------------------
HTTP/1.1 401 Unauthorized
WWW-Authenticate: GoogleLogin
realm="https://www.google.com/accounts/ClientLogin", service="blogger"
WWW-Authenticate: AuthSub
realm="https://www.google.com/accounts/AuthSubRequest",
service="blogger"
Content-Type: text/plain; charset=UTF-8
Transfer-Encoding: chunked
Cache-control: private
Date: Sun, 16 Dec 2007 01:19:20 GMT
Server: GFE/1.3

30
User does not have permission to create new post

0

---------------------------------------------------------------------------------------


which is new (and password has been verified fyi), b/c this used to work.

thoguhts or solutions?
-w

Mime
View raw message