abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris Berry <chriswbe...@gmail.com>
Subject Re: maven-issues deploying and retrofying
Date Tue, 11 Dec 2007 14:12:16 GMT
It appears that you need to set up the  http://people.apache.org/repo/ 
m2-incubating-repository with SNAPSHOTs enabled

<settings>
   ...
   <profiles>
     <profile>
       <id>apache</id>
       <repositories>
         <repository>
           <id>apache.org</id>
           <url>http://people.apache.org/repo/m2-snapshot-repository</ 
url>
           <releases>
             <enabled>false</enabled>
           </releases>
           <snapshots>
             <enabled>true</enabled>
           </snapshots>
         </repository>
       </repositories>


On Dec 11, 2007, at 7:04 AM, herbert wrote:

>
> Hi!
>
> I'm trying to bring myself uptodate and to use the current abdera- 
> code out
> of the trunk.
>
> I've installed maven, checked out the trunk and followed the  
> instructions in
> the document BUILDING.
> (1. mvn install, 2. mvn eclipse:eclipse, 3.import as eclipse-projects)
> Now I've lots of abera-sub-projects as eclipse-projects in my IDE.  
> None of
> the projects shows any error.
>
> So far, so good.
> When I select the pom.xml-file in the abdera-client-project and  
> execute "run
> as"->"maven build"->"goal: validate" I get an error, that I  
> appended at the
> end of this posting.
>
> 1. Any ideas, what goes wrong here?
>
> 2. Is there a maven-goal built in, that retrofies the created jar- 
> files as
> JDK-1.4.-versions?
>
> Regards, Herbert
>
> Here comes the error:
>
> [WARN] Unable to get resource from repository apache.incubating
> (http://people.apache.org/repo/m2-incubating-repository)
>
> org.apache.maven.artifact.resolver.MultipleArtifactsNotFoundException:
> Missing:
> ----------
> 1) org.apache.abdera:abdera-parser:jar:0.4.0-incubating-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.abdera
> -DartifactId=abdera-parser \
>           -Dversion=0.4.0-incubating-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file
>
>   Path to dependency:
>   	1) org.apache.abdera:abdera-client:jar:0.4.0-incubating-SNAPSHOT
>   	2) org.apache.abdera:abdera-parser:jar:0.4.0-incubating-SNAPSHOT
>
> 2) org.apache.abdera:abdera-protocol:jar:0.4.0-incubating-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.abdera
> -DartifactId=abdera-protocol \
>           -Dversion=0.4.0-incubating-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file
>
>   Path to dependency:
>   	1) org.apache.abdera:abdera-client:jar:0.4.0-incubating-SNAPSHOT
>   	2) org.apache.abdera:abdera-protocol:jar:0.4.0-incubating-SNAPSHOT
>
> 3) org.apache.abdera:abdera-core:jar:0.4.0-incubating-SNAPSHOT
>
>   Try downloading the file manually from the project website.
>
>   Then, install it using the command:
>       mvn install:install-file -DgroupId=org.apache.abdera
> -DartifactId=abdera-core \
>           -Dversion=0.4.0-incubating-SNAPSHOT -Dpackaging=jar
> -Dfile=/path/to/file
>
>   Path to dependency:
>   	1) org.apache.abdera:abdera-client:jar:0.4.0-incubating-SNAPSHOT
>   	2) org.apache.abdera:abdera-core:jar:0.4.0-incubating-SNAPSHOT
>
> ----------
> 3 required artifacts are missing.
>
> for artifact:
>   org.apache.abdera:abdera-client:jar:0.4.0-incubating-SNAPSHOT
>
> from the specified remote repositories:
>   central (http://repo1.maven.org/maven2),
>   apache.incubating (http://people.apache.org/repo/m2-incubating- 
> repository)
>
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTran 
> sitively(DefaultArtifactResolver.java:244)
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTran 
> sitively(DefaultArtifactResolver.java:211)
> 	at
> org.apache.maven.artifact.resolver.DefaultArtifactResolver.resolveTran 
> sitively(DefaultArtifactResolver.java:192)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.buildWithDependenc 
> ies(DefaultMavenProjectBuilder.java:342)
> 	at
> org.apache.maven.project.DefaultMavenProjectBuilder.buildWithDependenc 
> ies(DefaultMavenProjectBuilder.java:289)
> 	at
> org.apache.maven.embedder.MavenEmbedder.readProjectWithDependencies 
> (MavenEmbedder.java:277)
> 	at org.maven.ide.eclipse.Maven2Executor.main(Maven2Executor.java:53)
>
>
> -- 
> View this message in context: http://www.nabble.com/maven-issues- 
> deploying-and-retrofying-tp14273445p14273445.html
> Sent from the abdera-user mailing list archive at Nabble.com.
>

S'all good  ---   chriswberry at gmail dot com




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message