abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James M Snell <jasn...@gmail.com>
Subject Re: [Fwd: [jira] Updated: (ABDERA-61) Invalid byte 2 of 3-byte UTF-8 sequence]
Date Thu, 06 Sep 2007 03:29:28 GMT
Good to hear.  I'll wait to hear back from Herbert before I commit the
patch.

- James

Chris Berry wrote:
> I have applied this patch to a fresh checkout of 0.3-SNAPSHOT and it
> corrects my UTF-8 problems
> Thanks James !!
> Cheers,
> -- Chris
> 
> On Sep 5, 2007, at 7:29 PM, James M Snell wrote:
> 
>> Please give this patch a try.  This is a refactored version of what
>> Chris provided earlier.
>>
>> -------- Original Message --------
>> [snip]
>>
>> James M Snell updated ABDERA-61:
>> --------------------------------
>>
>>     Attachment: patch.diff
>>
>> Here's a refactored version of the change Chris posted to the list.
>> This should be a bit more robust and will hopefully address the problem.
>>  Please give this a test in your local environments and if it works,
>> I'll commit the change to the trunk and the 0.3.0 branch.
>>
>>> Invalid byte 2 of 3-byte UTF-8 sequence
>>> ---------------------------------------
>>>
>>>                 Key: ABDERA-61
>>>                 URL: https://issues.apache.org/jira/browse/ABDERA-61
>>>             Project: Abdera
>>>          Issue Type: Bug
>>>    Affects Versions: 0.2.2, 0.3.0
>>>         Environment: The System runs a RAD 7.0.0.3 on Windows XP
>>> Professional
>>> The JDK is:
>>> C:\Programme\IBM\SDP70\jdk\bin>java -version
>>> java version "1.5.0"
>>> Java(TM) 2 Runtime Environment, Standard Edition (build
>>> pwi32devifx-20070323 (if
>>> ix 117674: SR4 + 116644 + 114941 + 116110 + 114881))
>>> IBM J9 VM (build 2.3, J2RE 1.5.0 IBM J9 2.3 Windows XP x86-32
>>> j9vmwi3223ifx-2007
>>> 0323 (JIT enabled)
>>> J9VM - 20070322_12058_lHdSMR
>>> JIT  - 20070109_1805ifx3_r8
>>> GC   - WASIFIX_2007)
>>> JCL  - 20070131
>>> But the program runs under JDK-Compliance-Level-1.4
>>> The Lotus-Connections-Server runs on a WebSphere 6.1.0.9 on a Windows
>>> XP Professional System.
>>>            Reporter: herbert welker
>>>         Attachments: patch.diff, UTF-8-problem.zip
>>>
>>>
>>> When trying to create an Atom-Entry with the abdera-0.22-client on a
>>> Lotus-Connections-Server, the server (Lotus-Connections-1.0.1)
>>> responds with a HTTP-400-Error-message:
>>> org.xml.sax.SAXParseException: Invalid byte 2 of 3-byte UTF-8 sequence.
>>> Some googleing gives "...The most likely cause is that the document
>>> you are uploading specifies that it is in UTF-8 encoding, but that it
>>> contains non-UTF-8 characters. As UTF-8 is the default character set
>>> for XML, it might also be the case that the document does not specify
>>> a character set at all."
>>> More description and the java-code of my client is given in the
>>> attached files.
>>
>> -- 
>> This message is automatically generated by JIRA.
>> -
>> You can reply to this email to add a comment to the issue online.
>>
>>
> 
> S'all good  ---   chriswberry at gmail dot com
> 
> 
> 
> 

Mime
View raw message