abdera-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From herbert <i...@gmx.de>
Subject Next "JDK 5.0 vs. JDK 1.4.2"-problem with abdera 0.3.0, "ExceptionInInitializerError"
Date Mon, 10 Sep 2007 08:58:38 GMT

Hi all!

I made the next step towards integrating the new abdera-0.3.0-zips in my JDK
1.4.2-project.
When trying to post an entry to a server I get an exception, that I appended
at the end of thist posting.

With a plain 1.4.2-JVM my testcode does *not* work (see the exception).

These are the 1.4.2-JVM-details:

{java.assistive=ON, java.runtime.name=Java(TM) 2 Runtime Environment,
Standard Edition,
sun.boot.library.path=C:\Programme\IBM\SDP70\runtimes\base_v51_stub\java\jre\bin,
java.vm.version=1.4.2, java.vm.vendor=IBM Corporation,
java.vendor.url=http://www.ibm.com/, path.separator=;, java.vm.name=Classic
VM, file.encoding.pkg=sun.io, user.country=DE, sun.os.patch.level=Service
Pack 2, java.vm.specification.name=Java Virtual Machine Specification,
user.dir=C:\workspace\AbderaTest, java.runtime.version=1.4.2,
java.fullversion=J2RE 1.4.2 IBM Windows 32 build cn142-20060824 (SR6) (JIT
enabled: jitc), java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment,
java.endorsed.dirs=C:\Programme\IBM\SDP70\runtimes\base_v51_stub\java\jre\lib\endorsed,
os.arch=x86, com.ibm.vm.bitmode=32...

With the RAD-7.0-default-JVM, set up to be 1.4-compliant, my testcode *does*
work.

These are the RAD-7.0-default-JVM-details:

{java.assistive=ON, java.runtime.name=Java(TM) 2 Runtime Environment,
Standard Edition, ibm.signalhandling.rs=false,
sun.boot.library.path=C:\Programme\IBM\SDP70\jdk\jre\bin,
java.vm.version=2.3, com.ibm.oti.configuration=scar, java.vm.vendor=IBM
Corporation, java.vendor.url=http://www.ibm.com/, path.separator=;,
java.vm.name=IBM J9 VM, user.country=DE, java.vm.specification.name=Java
Virtual Machine Specification, user.dir=C:\workspace\AbderaTest,
java.runtime.version=pwi32devifx-20070323 (ifix 117674: SR4 + 116644 +
114941 + 116110 + 114881), java.fullversion=J2RE 1.5.0 IBM J9 2.3 Windows XP
x86-32 j9vmwi3223ifx-20070323 (JIT enabled)
J9VM - 20070322_12058_lHdSMR
JIT  - 20070109_1805ifx3_r8
GC   - WASIFIX_2007, java.awt.graphicsenv=sun.awt.Win32GraphicsEnvironment,
os.arch=x86, com.ibm.vm.bitmode=32...

Any idea, what the problem could be?

Regards,

Herbert

Here comes the exception, that occurs with the plain 1.4.2-JVM:

org.apache.abdera.protocol.client.ClientException:
java.lang.ExceptionInInitializerError
	at
org.apache.abdera.protocol.client.AbderaClient.execute(AbderaClient.java:415)
	at
org.apache.abdera.protocol.client.AbderaClient.post(AbderaClient.java:156)
	at ServiceImpl.createActivity(ServiceImpl.java:134)
	at 
ServiceImplTest.testCreateActivity1(ServiceImplTest.java:38)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:85)
	at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:58)
	at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:60)
	at java.lang.reflect.Method.invoke(Method.java:391)
	at junit.framework.TestCase.runTest(TestCase.java:154)
	at junit.framework.TestCase.runBare(TestCase.java:127)
	at junit.framework.TestResult$1.protect(TestResult.java:106)
	at junit.framework.TestResult.runProtected(TestResult.java:124)
	at junit.framework.TestResult.run(TestResult.java:109)
	at junit.framework.TestCase.run(TestCase.java:118)
	at junit.framework.TestSuite.runTest(TestSuite.java:208)
	at junit.framework.TestSuite.run(TestSuite.java:203)
	at
org.eclipse.jdt.internal.junit.runner.junit3.JUnit3TestReference.run(JUnit3TestReference.java:128)
	at
org.eclipse.jdt.internal.junit.runner.TestExecution.run(TestExecution.java:38)
	at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:460)
	at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.runTests(RemoteTestRunner.java:673)
	at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.run(RemoteTestRunner.java:386)
	at
org.eclipse.jdt.internal.junit.runner.RemoteTestRunner.main(RemoteTestRunner.java:196)
Caused by: java.lang.ExceptionInInitializerError
	at org.apache.axiom.om.impl.llom.OMNodeImpl.serialize(OMNodeImpl.java:408)
	at org.apache.abdera.parser.stax.FOMElement.writeTo(FOMElement.java:401)
	at org.apache.abdera.parser.stax.FOMElement.writeTo(FOMElement.java:393)
	at
org.apache.abdera.protocol.client.util.BaseRequestEntity.getContentLength(BaseRequestEntity.java:75)
	at
org.apache.commons.httpclient.methods.EntityEnclosingMethod.getRequestContentLength(EntityEnclosingMethod.java:336)
	at
org.apache.commons.httpclient.methods.EntityEnclosingMethod.addContentLengthRequestHeader(EntityEnclosingMethod.java:406)
	at
org.apache.commons.httpclient.methods.EntityEnclosingMethod.addRequestHeaders(EntityEnclosingMethod.java:374)
	at
org.apache.commons.httpclient.HttpMethodBase.writeRequestHeaders(HttpMethodBase.java:2173)
	at
org.apache.commons.httpclient.HttpMethodBase.writeRequest(HttpMethodBase.java:2056)
	at
org.apache.commons.httpclient.HttpMethodBase.execute(HttpMethodBase.java:1088)
	at
org.apache.commons.httpclient.HttpMethodDirector.executeWithRetry(HttpMethodDirector.java:398)
	at
org.apache.commons.httpclient.HttpMethodDirector.executeMethod(HttpMethodDirector.java:171)
	at
org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:397)
	at
org.apache.commons.httpclient.HttpClient.executeMethod(HttpClient.java:323)
	at
org.apache.abdera.protocol.client.AbderaClient.execute(AbderaClient.java:401)
	... 22 more
Caused by: java.lang.IllegalStateException: No valid ObjectCreator found.
	at org.apache.axiom.om.util.StAXUtils$Pool.<init>(StAXUtils.java:64)
	at org.apache.axiom.om.util.StAXUtils.<clinit>(StAXUtils.java:88)
	... 37 more

-- 
View this message in context: http://www.nabble.com/Next-%22JDK-5.0-vs.-JDK-1.4.2%22-problem-with-abdera-0.3.0%2C-%22ExceptionInInitializerError%22-tf4413228.html#a12589111
Sent from the abdera-user mailing list archive at Nabble.com.


Mime
View raw message