abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (ABDERA-428) Axiom dependency updated to version 1.2.15, axiom 1.2.14 is not supported in AIX machines with Java 7 and 8
Date Thu, 27 Aug 2015 22:14:45 GMT

    [ https://issues.apache.org/jira/browse/ABDERA-428?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14717643#comment-14717643
] 

Andreas Veithen commented on ABDERA-428:
----------------------------------------

Abdera (in particular the abdera-parser component) is tightly coupled to Axiom because it
extends internal implementation classes. That means that a given version of Abdera generally
only works with the Axiom version for which it has been designed. There is no way to make
Abdera 1.1.3 work with Axiom 1.2.15. On the other hand, the current Abdera trunk has been
updated to use Axiom 1.2.15, but given the lack of activity in the Abdera project, it is unlikely
that there will be a release anytime soon. Since that is obviously a problem for users who
can't use older Axiom versions, the Axiom project has forked the problematic abdera-parser
component (see http://svn.apache.org/r1687999) and will ship an up-to-date version with its
next release. That component can then be used with Abdera 1.1.3. If the Abdera project becomes
active again and plans to do a release, the Axiom project will hand back that code to be reintegrated
into Abdera.

In the meantime you have two options:
- Use a snapshot version of Abdera (see https://repository.apache.org/content/repositories/snapshots/org/apache/abdera/)
together with Axiom 1.2.15.
- Use Abdera 1.1.3 and replace abdera-parser with a snapshot version of fom-impl provided
by the Axiom project (see https://repository.apache.org/content/repositories/snapshots/org/apache/ws/commons/axiom/fom-impl/1.2.16-SNAPSHOT/).

> Axiom dependency updated to version 1.2.15, axiom 1.2.14 is not supported in AIX machines
with Java 7 and 8
> -----------------------------------------------------------------------------------------------------------
>
>                 Key: ABDERA-428
>                 URL: https://issues.apache.org/jira/browse/ABDERA-428
>             Project: Abdera
>          Issue Type: Bug
>    Affects Versions: 1.1.2, 1.1.3
>            Reporter: Divya
>             Fix For: 1.1.3
>
>
> Axiom dependency updated to version 1.2.15, axiom 1.2.14 is not supported in AIX machines
with Java 7 and 8
> The exception being thrown if I use axiom 1.2.14 as below
>     java.lang.IllegalArgumentException: The XMLInputFactory does not recognize the property
"reuse-instance"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message