abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ugo Cei <...@apache.org>
Subject Using Abdera in a Confluence plugin
Date Tue, 13 May 2008 12:57:01 GMT
Hi,

I'm currently trying to use Abdera 0.4.0 for generating Atom feeds  
from an Atlassian Confluence plugin. I suspect there are some  
classloader issues when using Abdera in this scenario, because if I  
use the following typical idiom:

abdera = new Abdera();
Feed feed = abdera.newFeed();

I get an NPE due to the fact that abdera.getFactory() returns null.  
Apparently the ServiceUtils class is not finding classes to load. I  
tried working around the issue by using my own version of  
AbderaConfiguration that "news" FOMFactory, FOMParser, etc. instead  
of relying on ServiceUtils (which confirms, by the way, that the  
various dependencies like Axiom are in the classpath), but I got  
stuck again with the following trace:

javax.servlet.ServletException: Servlet execution threw an exception
  at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter 
(ApplicationFilterChain.java:292)
...
caused by: java.lang.ExceptionInInitializerError
  at org.apache.axiom.om.impl.llom.OMNodeImpl.serialize 
(OMNodeImpl.java:408)
...
caused by: java.lang.IllegalStateException: No valid ObjectCreator  
found.
  at org.apache.axiom.om.util.StAXUtils$Pool.(StAXUtils.java:64)

Has anyone ever tried doing something similar or fallen into the same  
kind of problems? For the record, this is using Abdera 0.4.0 in  
Confluence 2.8, JDK 1.5 on OS X Tiger.

	Thanks in Advance

		Ugo


-- 
Ugo Cei
Sourcesense - making sense of Open Source: http://www.sourcesense.com


Mime
View raw message