abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ugo Cei <...@apache.org>
Subject Spring version for 0.4
Date Mon, 07 Apr 2008 16:23:51 GMT
Hi,

I'm trying to use Abdera 0.4 (imported with Maven from Dan's private  
repo) with Spring 2.0.2 and I get the following error when loading a  
context that includes an Abdera provider:

java.lang.AbstractMethodError:  
org.springframework.beans.factory.xml.AbstractSingleBeanDefinitionParser 
.getBeanClass(Lorg/w3c/dom/Element;)Ljava/lang/Class;
         at  
org.springframework.beans.factory.xml.AbstractSingleBeanDefinitionParser 
.parseInternal(AbstractSingleBeanDefinitionParser.java:58)

My context definition file looks like the following:

<beans xmlns="http://www.springframework.org/schema/beans"
   xmlns:a="http://abdera.apache.org"
   xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
   xsi:schemaLocation="
     http://www.springframework.org/schema/beans http:// 
www.springframework.org/schema/beans/spring-beans-2.0.xsd
     http://abdera.apache.org http://abdera.apache.org/schemas/abdera- 
spring.xsd">

   <!-- Abdera -->
   <a:provider id="provider">

     <a:workspace title="Foo Atom Workspace">
       <ref bean="fooCollectionAdapter"/>
     </a:workspace>

   </a:provider>

   <bean id="fooCollectionAdapter"  
class="org.foo.atom.DocumentCollectionAdapter">
     <property name="href" value="spaces"/>
   </bean>

</beans>

I have a hunch it depends on the version of Spring used, but I'm not  
sure. What version of Spring has the Abdera Spring integration stuff  
been tested with?

	TiA,

		Ugo


Mime
View raw message