abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Wells" <todd.we...@theplatform.com>
Subject JUnit failure building 0.3.0-incubating from source
Date Tue, 04 Mar 2008 12:58:45 GMT
When running a "mvn install", I get a single unit test failure:

 

  <testcase time="0.219" name="testSection4276LinkLengthNotPositive">

    <failure type="junit.framework.AssertionFailedError"
message="expected:&amp;lt;-1&amp;gt; but
was:&amp;lt;0&amp;gt;">junit.framework.AssertionFailedError:
expected:&amp;-1&amp; but was:&amp;0&amp;

                at junit.framework.Assert.fail(Assert.java:47)

                at junit.framework.Assert.failNotEquals(Assert.java:277)

                at junit.framework.Assert.assertEquals(Assert.java:64)

                at junit.framework.Assert.assertEquals(Assert.java:130)

                at junit.framework.Assert.assertEquals(Assert.java:136)

                at
org.apache.abdera.test.parser.stax.FeedValidatorTest.testSection4276Link
LengthNotPositive(FeedValidatorTest.java:3037)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)

                at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
a:39)

                at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
Impl.java:25)

                at java.lang.reflect.Method.invoke(Method.java:585)

                at junit.framework.TestCase.runTest(TestCase.java:168)

                at junit.framework.TestCase.runBare(TestCase.java:134)

                at
junit.framework.TestResult$1.protect(TestResult.java:110)

                at
junit.framework.TestResult.runProtected(TestResult.java:128)

                at junit.framework.TestResult.run(TestResult.java:113)

                at junit.framework.TestCase.run(TestCase.java:124)

                at junit.framework.TestSuite.runTest(TestSuite.java:232)

                at junit.framework.TestSuite.run(TestSuite.java:227)

                at
org.junit.internal.runners.OldTestClassRunner.run(OldTestClassRunner.jav
a:76)

                at
org.apache.maven.surefire.junit4.JUnit4TestSet.execute(JUnit4TestSet.jav
a:62)

                at
org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.executeTestSe
t(AbstractDirectoryTestSuite.java:138)

                at
org.apache.maven.surefire.suite.AbstractDirectoryTestSuite.execute(Abstr
actDirectoryTestSuite.java:125)

                at
org.apache.maven.surefire.Surefire.run(Surefire.java:132)

                at sun.reflect.NativeMethodAccessorImpl.invoke0(Native
Method)

                at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.jav
a:39)

                at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessor
Impl.java:25)

                at java.lang.reflect.Method.invoke(Method.java:585)

                at
org.apache.maven.surefire.booter.SurefireBooter.runSuitesInProcess(Suref
ireBooter.java:290)

                at
org.apache.maven.surefire.booter.SurefireBooter.main(SurefireBooter.java
:818)

</failure>

  </testcase>

 

I don't know if it's related, but I noticed this checksum failure during
the maven build, too:

 

[WARNING] *** CHECKSUM FAILED - Error retrieving checksum file for
org/codehaus/woodstox/wstx-asl/3.2.1/wstx-asl-3.2.1.jar - IGNORING

 

My apologies if this is the incorrect list for posting this issue, it
seemed appropriate since it had to do with building the source.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message