abdera-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "vasu nori (JIRA)" <j...@apache.org>
Subject [jira] Commented: (ABDERA-116) JdbcCollectionAdapter class name and package are ambiguous
Date Tue, 12 Feb 2008 18:11:09 GMT

    [ https://issues.apache.org/jira/browse/ABDERA-116?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12568263#action_12568263
] 

vasu nori commented on ABDERA-116:
----------------------------------

I would disagree.

JdbcAdapter could probably be named DbAdapter. It is an adapter between Abdera server &
databases. (relational databases, to be precise).

ibatis is part of the adapter-code. in fact, would be nice to have different implementation
of "JdbcAdapter" using hibernate or any other OR mapping layer.




> JdbcCollectionAdapter class name and package are ambiguous
> ----------------------------------------------------------
>
>                 Key: ABDERA-116
>                 URL: https://issues.apache.org/jira/browse/ABDERA-116
>             Project: Abdera
>          Issue Type: Improvement
>            Reporter: David Calavera
>             Fix For: 0.4.0
>
>         Attachments: ibatisAdapter.patch
>
>
> JdbcCollectionAdapter class name is ambiguous because it uses ibatis library to connect
the database instead of a native jdbc connector. This class should be renamed to IBatisCollectionAdapter
and moved to an appropiate package

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message